furlong 1.0.0-dev+4

  • README.md
  • Installing
  • Versions
  • 0

furlong #

SQLJocky migration tool. Will eventually work with SQLJocky2.

Todo #

  • Alterations
  • Model generators
  • Command-line executable
  • Grinder examples
  • More examples
  • Use inflection package for pluralization

Examples #

class SongMigration extends Migration {
  @override
  String get name => "Songs table";

  @override
  Future create(Migrator migrator) async {
    await migrator.create("songs", (TableSchema table) {
      table.primaryKey = table.integer("id", autoIncrement: true);
      
      table.string("artist_id");
      table.string("title");
      table.string("desc").nullable = true;
      table.timeStamp("created_at");
      table.timeStamp("updated_at");
    });
  }

  @override
  Future destroy(Migrator migrator) async {
    await migrator.drop(["songs"]);
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  furlong: ^1.0.0-dev+4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:furlong/furlong.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev+4 Sep 21, 2016 Go to the documentation of furlong 1.0.0-dev+4 Download furlong 1.0.0-dev+4 archive
1.0.0-dev+3 Sep 21, 2016 Go to the documentation of furlong 1.0.0-dev+3 Download furlong 1.0.0-dev+3 archive
1.0.0-dev+2 Sep 21, 2016 Go to the documentation of furlong 1.0.0-dev+2 Download furlong 1.0.0-dev+2 archive
1.0.0-dev+1 Sep 20, 2016 Go to the documentation of furlong 1.0.0-dev+1 Download furlong 1.0.0-dev+1 archive
1.0.0-dev Sep 18, 2016 Go to the documentation of furlong 1.0.0-dev Download furlong 1.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.