furlong 1.0.0-dev+4

  • README.md
  • Installing
  • Versions
  • 33

furlong

SQLJocky migration tool. Will eventually work with SQLJocky2.

Todo

  • Alterations
  • Model generators
  • Command-line executable
  • Grinder examples
  • More examples
  • Use inflection package for pluralization

Examples

class SongMigration extends Migration {
  @override
  String get name => "Songs table";

  @override
  Future create(Migrator migrator) async {
    await migrator.create("songs", (TableSchema table) {
      table.primaryKey = table.integer("id", autoIncrement: true);
      
      table.string("artist_id");
      table.string("title");
      table.string("desc").nullable = true;
      table.timeStamp("created_at");
      table.timeStamp("updated_at");
    });
  }

  @override
  Future destroy(Migrator migrator) async {
    await migrator.drop(["songs"]);
  }
}

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  furlong: "^1.0.0-dev+4"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:furlong/furlong.dart';
        
Version Uploaded Documentation Archive
1.0.0-dev+4 Sep 21, 2016 Go to the documentation of furlong 1.0.0-dev+4 Download furlong 1.0.0-dev+4 archive
1.0.0-dev+3 Sep 21, 2016 Go to the documentation of furlong 1.0.0-dev+3 Download furlong 1.0.0-dev+3 archive
1.0.0-dev+2 Sep 21, 2016 Go to the documentation of furlong 1.0.0-dev+2 Download furlong 1.0.0-dev+2 archive
1.0.0-dev+1 Sep 20, 2016 Go to the documentation of furlong 1.0.0-dev+1 Download furlong 1.0.0-dev+1 archive
1.0.0-dev Sep 18, 2016 Go to the documentation of furlong 1.0.0-dev Download furlong 1.0.0-dev archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
90 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
31 / 100
Overall score:
Weighted score of the above. [more]
33
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:furlong/furlong.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 3 errors 10 hints.

    Strong-mode analysis of lib/src/mysql/enumerator.dart failed with the following error:

    line: 10 col: 3
    Invalid override. The type of '_Enumerator.defaultValue=' ('(String) → void') isn't a subtype of '_FieldGenerator.defaultValue=' ('(dynamic) → void').

    Strong-mode analysis of lib/src/mysql/int.dart failed with the following error:

    line: 79 col: 3
    Invalid override. The type of '_BigInt._defaultValue' ('() → num') isn't a subtype of '_Int._defaultValue' ('() → int').

    Similar analysis of the following files failed:

    • lib/src/mysql/text.dart (error)
    • lib/furlong.dart (hint)
    • lib/src/furlong.dart (hint)
    • lib/src/migration.dart (hint)
    • lib/src/migrator.dart (hint)
    • lib/src/mysql/date.dart (hint)
    • lib/src/mysql/mysql_table_schema.dart (hint)
    • lib/src/mysql/string.dart (hint)
  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use furlong.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
grinder >=0.8.0 <1.0.0 0.8.1
intl >=0.14.0 <0.15.0 0.14.0 0.15.6
sqljocky >=0.14.1 <1.0.0 0.14.1
Transitive dependencies
async 2.0.6
charcode 1.1.1
cli_util 0.1.2+1
collection 1.14.9
convert 1.1.1 2.0.1
crypto 0.9.2+1 2.0.2+1
glob 1.1.5
logging 0.11.3+1
options_file 0.11.0
path 1.5.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
http >=0.11.3 <0.12.0
test >=0.12.13 <0.13.0