gamee 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

gamee

A Dart wrapper around http://gameeapp.com project.

Usage

A simple usage example:

import 'package:gamee/gamee.dart';

main() {
  Gamee gamee = new Gamee(context[r"$gameeNative"]);
}

Features and bugs

This version is a prototype. Basic functional version will come soon.

Changelog

0.0.1

  • First wrapper version

example/gamee_example.dart

// Copyright (c) 2016, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library gamee.example;

import 'package:gamee/gamee.dart';

main() {
  var awesome = new Awesome();
  print('awesome: ${awesome.isAwesome}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gamee: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gamee/gamee.dart';
  
Version Uploaded Documentation Archive
0.0.2 Feb 19, 2016 Go to the documentation of gamee 0.0.2 Download gamee 0.0.2 archive
0.0.1 Feb 19, 2016 Go to the documentation of gamee 0.0.1 Download gamee 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0