generator_plus 0.0.2+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Generator+ logo

generator-plus

todos:

  • [ ] Files constraint controller watcher daemon
  • [ ] Directory locked for creation (forces use of X generator)
  • [ ] Certain lines must be filled with code.
  • [ ] Lines hidden by default and lazily deleted when filled (i.e. throw Execption("Failing because of method not implemented"))
  • [ ] Lines of code locked from changes

Changelog

0.0.2

  • Updated pubspec.yaml constraints and adapted code for it

0.0.1

  • Initial version, created by Stagehand

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate generator_plus

2. Use it

The package has the following executables:


$ generator-plus

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  generator_plus: ^0.0.2+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:generator_plus/generator_plus.dart';
  
Version Uploaded Documentation Archive
0.0.2+1 Feb 25, 2018 Go to the documentation of generator_plus 0.0.2+1 Download generator_plus 0.0.2+1 archive
0.0.2 Jan 29, 2018 Go to the documentation of generator_plus 0.0.2 Download generator_plus 0.0.2 archive
0.0.1 Nov 6, 2017 Go to the documentation of generator_plus 0.0.1 Download generator_plus 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0