generic_vector_tools 1.0.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 18

generic_vector_tools

A library for Vectors of arbitrary length, and arbitrary element types. Makes use of operator overloads of elements to perform operations.

Usage

A simple usage example:

import 'package:generic_vector_tools/generic_vector_tools.dart';

main() {
  V<double> position = new V<double>([0.0, 10.0]);
  V positions = new V([position, position + 10.0, position + 25.0]);
  V morePositions = new V([position, position + 90.0, position + 11.1]);

  V yetMorePositions = positions + morePositions;
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

1.0.0

  • Initial publish version, basic features and unit tests.

1.0.1

  • Added some documentation

1.0.2

  • Added negate methods to V and M
  • Added sum(), sumRecursive(), any() and every() to V

1.0.3

  • SelfResolve
  • Split unit tests into separate files
  • Try and convert basic constructor input to list
  • docs for M
  • generic constructor for m and unit tests
  • zip uses generic constructor

1.0.4

  • V2 now extends V
  • explicitly set V list sizes where relevant

1.0.5

  • removed the type checking for V.generic, it caused issues when compiled to js

1.0.6

  • fixed unit tests not working in checked mode

1.0.7

  • Unit tests make use of the test package (pub run test...) rather than a custom command.
  • More flexible V2 overloads.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  generic_vector_tools: "^1.0.7"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:generic_vector_tools/generic_vector_tools.dart';
        
Version Uploaded Documentation Archive
1.0.7 Jul 11, 2016 Go to the documentation of generic_vector_tools 1.0.7 Download generic_vector_tools 1.0.7 archive
1.0.6 Apr 3, 2016 Go to the documentation of generic_vector_tools 1.0.6 Download generic_vector_tools 1.0.6 archive
1.0.5 Apr 2, 2016 Go to the documentation of generic_vector_tools 1.0.5 Download generic_vector_tools 1.0.5 archive
1.0.4 Feb 14, 2016 Go to the documentation of generic_vector_tools 1.0.4 Download generic_vector_tools 1.0.4 archive
1.0.3 Feb 7, 2016 Go to the documentation of generic_vector_tools 1.0.3 Download generic_vector_tools 1.0.3 archive
1.0.2 Feb 3, 2016 Go to the documentation of generic_vector_tools 1.0.2 Download generic_vector_tools 1.0.2 archive
1.0.1 Feb 3, 2016 Go to the documentation of generic_vector_tools 1.0.1 Download generic_vector_tools 1.0.1 archive
1.0.0 Jan 29, 2016 Go to the documentation of generic_vector_tools 1.0.0 Download generic_vector_tools 1.0.0 archive

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
1 / 100
Health:
Code health derived from static analysis. [more]
45 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
20 / 100
Overall score:
Weighted score of the above. [more]
18
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:generic_vector_tools/generic_vector_tools.dart.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 11 errors 2 hints.

    Strong-mode analysis of lib/src/m.dart failed with the following error:

    line: 189 col: 3
    Invalid override. The type of 'M.==' ('(M) → bool') isn't a subtype of 'Object.==' ('(dynamic) → bool').

    Strong-mode analysis of lib/src/v.dart failed with the following error:

    line: 25 col: 30
    The operator '*' isn't defined for the class 'Object'.

    Similar analysis of the following files failed:

    • lib/src/v2.dart (error)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
Dev dependencies
test >=0.12.0 <0.13.0