geo 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 84

Dart Geo

This project provides a set of utility functions for geographic computations.

License

Apache 2.0

0.2.0 (2018-08-01)

  • Migration to Dart 2.

0.1.0

  • no more range control for lat and lng in LatLng constructor. This is mainly to handle bounded boxes across antemeridian.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  geo: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:geo/geo.dart';
  
Version Uploaded Documentation Archive
0.2.0 Aug 2, 2018 Go to the documentation of geo 0.2.0 Download geo 0.2.0 archive
0.1.0 Jul 7, 2017 Go to the documentation of geo 0.1.0 Download geo 0.1.0 archive
0.0.2 Jan 31, 2014 Go to the documentation of geo 0.0.2 Download geo 0.0.2 archive
0.0.1 Jan 16, 2014 Go to the documentation of geo 0.0.1 Download geo 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
71
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:geo/geo.dart.

Suggestions

Maintain an example.

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use geo.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.62.0 <3.0.0
meta ^1.0.5 1.1.6
Dev dependencies
test ^1.3.0