gestures 0.0.1

  • Installing
  • Versions
  • 77

Gestures #

pub package

Custom Gesture Detector for Flutter. Empower your users with custom gestures.

How to use #

In your pubspec.yaml:

  gestures: ^0.0.1
import 'package:gestures/gestures.dart';

Basic construction of the widget:

  gestures: [
  onGestureEnd: (success) {
    if (success) {
      // TODO: your action here..
  child: Container(),

License #

Licensed under the MIT license.

[0.0.1] - 2019/01/30

  • Initial release with custom gestures widget and basic line gesture detection.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  gestures: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:gestures/gestures.dart';
Version Uploaded Documentation Archive
0.0.1 Jan 30, 2019 Go to the documentation of gestures 0.0.1 Download gestures 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/gestures.dart.

Run flutter format to format lib/gestures.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and gestures.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies