git 0.5.1+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 71

A dart wrapper around the Git command line

Build Status

Authors

0.5.1+1

  • Support Dart 2 stable releases.

  • Drop support for Dart 1.

0.5.1

  • GitDir.fromExisting added a allowSubdirectory parameter.

0.5.0

  • Remove unsupported dependencies.

0.4.4+3

  • Strong-mode fixes.

0.4.4+2

  • Internal refactoring.

0.4.4+1

  • Run git in the shell – trying to address issues on Windows.

0.4.4

  • Use which package to try harder to find git executable.

0.4.3

  • GitDir added updateBranchWithDirectoryContents.

0.4.2

  • Migrated code to Dart 1.9 async.

  • Improved testing.

0.4.1+2

  • Updated max version of bot dependency.

0.4.1+1

  • Updated hop and added hop_unittest dev dependencies.

0.4.1 - 2014-05-06

  • Tweaks to Commit to stop using deperecated APIs from bot.
  • Updated constraint on bot package.

0.4.0 - 2014-04-12

  • Made fields on TreeEntry final.
  • A lot of source clean up.

0.3.0 - 2014-03-17

  • BREAKING PopulateTempDir typedef.
  • BREAKING GitDir.populateBranch - moving away from TempDir from bot_io
  • Removed a number of package dependencies

0.2.1+1 - 2014-03-16

  • Moved scheduled_test dependency to dev_dependencies

0.2.1 - 2014-03-16

  • Deprecated PopulateTempDir typedef.
  • Deprecated GitDir.populateBranch - moving away from TempDir from bot_io
  • NEW! GitDir.updateBranch like populateBranch, but exposes a Directory

0.2.0 - 2014-03-04

  • Supporting next release of bot_io
  • Fixed hop_runner
  • Removed deprecated Git class.

0.1.0 - 2014-02-15

  • First release
  • Maintains 100% compatibility with the bot_git library from the bot_io package as of release 0.25.1+2.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  git: ^0.5.1+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:git/git.dart';
  
Version Uploaded Documentation Archive
0.5.1+1 Jul 23, 2018 Go to the documentation of git 0.5.1+1 Download git 0.5.1+1 archive
0.5.1 Mar 9, 2018 Go to the documentation of git 0.5.1 Download git 0.5.1 archive
0.5.0 Mar 9, 2018 Go to the documentation of git 0.5.0 Download git 0.5.0 archive
0.4.4+3 Dec 12, 2017 Go to the documentation of git 0.4.4+3 Download git 0.4.4+3 archive
0.4.4+2 Oct 29, 2015 Go to the documentation of git 0.4.4+2 Download git 0.4.4+2 archive
0.4.4+1 Apr 16, 2015 Go to the documentation of git 0.4.4+1 Download git 0.4.4+1 archive
0.4.4 Apr 16, 2015 Go to the documentation of git 0.4.4 Download git 0.4.4 archive
0.4.3 Apr 7, 2015 Go to the documentation of git 0.4.3 Download git 0.4.3 archive
0.4.2 Apr 4, 2015 Go to the documentation of git 0.4.2 Download git 0.4.2 archive
0.4.1+2 Jan 14, 2015 Go to the documentation of git 0.4.1+2 Download git 0.4.1+2 archive

All 21 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
53
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, other

Primary library: package:git/git.dart with components: io.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use git.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
path ^1.0.0 1.6.2
Dev dependencies
test ^1.0.0
test_descriptor ^1.0.3