git_url_parse 0.1.0

  • Installing
  • Versions
  • 0


Build Status License Dart

A high level git url parser for common git providers.


import 'package:git_url_parse/git-url-parse.dart' show gitUrlParse;

void main(){
  Map<String,dynamic> gitUrlInfo = gitUrlParse('');
# print out
  "href": "",
  "protocols": [
  "protocol": "https",
  "port": 443,
  "host": "",
  "user": "gpmer",
  "password": "",
  "origin": "",
  "path": "/gpm.js.git",
  "query": "",
  "hash": "",
  "source": "",
  "name": "gpm.js",
  "owner": "gpmer",
  "full_name": "gpmer/gpm.js"




git clone && cd ./git-url-parse
pub get


The MIT License

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  git_url_parse: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:git_url_parse/git-url-parse.dart';
Version Uploaded Documentation Archive
0.1.0 Mar 2, 2017 Go to the documentation of git_url_parse 0.1.0 Download git_url_parse 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because git_url_parse depends on url_parse any which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/git-url-parse.dart.

Run dartfmt to format lib/git-url-parse.dart.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

Package is getting outdated. (-77.26 points)

The package was released 92 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use git_url_parse.dart.