git_url_parse 0.1.0

  • README.md
  • Installing
  • Versions
  • 0

git-url-parse

Build Status License Dart

A high level git url parser for common git providers.

Usage

import 'package:git_url_parse/git-url-parse.dart' show gitUrlParse;

void main(){
  Map<String,dynamic> gitUrlInfo = gitUrlParse('https+git@github.com:gpmer/gpm.js.git');
  
  print(urlInfo);
}
# print out
{
  "href": "https+git@github.com:gpmer/gpm.js.git",
  "protocols": [
    "https",
    "git"
  ],
  "protocol": "https",
  "port": 443,
  "host": "github.com",
  "user": "gpmer",
  "password": "",
  "origin": "https+git@github.com",
  "path": "/gpm.js.git",
  "query": "",
  "hash": "",
  "source": "github.com",
  "name": "gpm.js",
  "owner": "gpmer",
  "full_name": "gpmer/gpm.js"
}

Test

./TEST

Contribute

git clone https://github.com/axetroy/git-url-parse.git && cd ./git-url-parse
pub get
./TEST

LICENSE

The MIT License

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  git_url_parse: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:git_url_parse/git-url-parse.dart';
  
Version Uploaded Documentation Archive
0.1.0 Mar 2, 2017 Go to the documentation of git_url_parse 0.1.0 Download git_url_parse 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because git_url_parse depends on url_parse any which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/git-url-parse.dart.

Run dartfmt to format lib/git-url-parse.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is getting outdated. (-62.19 points)

The package was released 84 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use git_url_parse.dart.