github_hook 0.2.2+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

A Shelf handler for managed GitHub hook messages

0.2.2+1

  • Upgrade dependencies.

0.2.2

  • Added user field to Issue.

0.2.1

  • Added body field to Issue.

0.2.0

  • Added a number of typed properties to IssueHookRequest.

  • Removed shelfRequest from HookRequest.

0.1.0

  • Renamed GitHubHookRequest to HookRequest.

  • Added IssuesHookRequest subclass.

0.0.1

  • Getting started...

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  github_hook: ^0.2.2+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:github_hook/github_hook.dart';
  
Version Uploaded Documentation Archive
0.2.2+1 Aug 13, 2016 Go to the documentation of github_hook 0.2.2+1 Download github_hook 0.2.2+1 archive
0.2.2 Aug 26, 2015 Go to the documentation of github_hook 0.2.2 Download github_hook 0.2.2 archive
0.2.1 Jul 15, 2015 Go to the documentation of github_hook 0.2.1 Download github_hook 0.2.1 archive
0.2.0 Jul 10, 2015 Go to the documentation of github_hook 0.2.0 Download github_hook 0.2.0 archive
0.0.1 Jun 18, 2015 Go to the documentation of github_hook 0.0.1 Download github_hook 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.17.0 <2.0.0