gitignore 0.2.0+1

  • README.md
  • Installing
  • Versions
  • 0

A simple tool for auto-generating a canonical .gitignore file in a directory.

Using gitignore

You can use pub to globally activate gitignore on your path:

$ pub global activate gitignore
$ mkdir new_project && cd new_project
$ gitignore

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate gitignore

2. Use it

The package has the following executables:


$ gitignore
Version Uploaded Documentation Archive
0.2.0+1 Sep 10, 2016 Go to the documentation of gitignore 0.2.0+1 Download gitignore 0.2.0+1 archive
0.2.0 Sep 9, 2016 Go to the documentation of gitignore 0.2.0 Download gitignore 0.2.0 archive
0.1.0-dev Sep 8, 2016 Go to the documentation of gitignore 0.1.0-dev Download gitignore 0.1.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use gitignore.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
path >=1.0.0 <2.0.0 1.6.2
Dev dependencies
test >=0.12.0 <0.13.0