This is a dart library to communicate with the GitLab API v4.
This is still work in progress. We are happy about Merge Requests!
This library is already in production use, but it is missing a lot of calls and properties.
The calls that are present should be safe to use.
There are still tests missing for a lot of resources though.
Simply add it to your project as a dependency:
dependencies: gitlab: any
For the full documentation, and usage, please refer to the documentation.
intldependency to include
Introduces basic commands and most of the properties of the most important entities
Add this to your package's pubspec.yaml file:
dependencies: gitlab: "^0.2.3"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.2.3||Jul 5, 2017|
|0.2.2||Jun 26, 2017|
|0.2.1||May 2, 2017|
|0.2.0||May 2, 2017|
|0.1.3||Feb 28, 2017|
|0.1.2||Feb 15, 2017|
|0.1.1||Feb 15, 2017|
|0.1.0||Feb 15, 2017|
We analyzed this package, and provided a score, details, and suggestions below.
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, web, other
No platform restriction found in primary library
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=1.21.0 <2.0.0|