gitlab 0.1.0

  • README.md
  • Installing
  • Versions
  • 11

GitLab API

build status

This is a dart library to communicate with the GitLab API v3.

This is still work in progress. We are happy about Merge Requets!

Installation

Simply add it to your project as a dependency:

dependencies:
  gitlab: any

Usage

For the full documentation, and usage, please refer to the documentation.

License

MIT

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gitlab: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gitlab/gitlab.dart';
  
Version Uploaded Documentation Archive
0.4.1 Aug 23, 2018 Go to the documentation of gitlab 0.4.1 Download gitlab 0.4.1 archive
0.4.0 Aug 17, 2018 Go to the documentation of gitlab 0.4.0 Download gitlab 0.4.0 archive
0.3.0 Aug 8, 2018 Go to the documentation of gitlab 0.3.0 Download gitlab 0.3.0 archive
0.2.3 Jul 5, 2017 Go to the documentation of gitlab 0.2.3 Download gitlab 0.2.3 archive
0.2.2 Jun 26, 2017 Go to the documentation of gitlab 0.2.2 Download gitlab 0.2.2 archive
0.2.1 May 2, 2017 Go to the documentation of gitlab 0.2.1 Download gitlab 0.2.1 archive
0.2.0 May 2, 2017 Go to the documentation of gitlab 0.2.0 Download gitlab 0.2.0 archive
0.1.3 Feb 28, 2017 Go to the documentation of gitlab 0.1.3 Download gitlab 0.1.3 archive
0.1.2 Feb 15, 2017 Go to the documentation of gitlab 0.1.2 Download gitlab 0.1.2 archive
0.1.1 Feb 15, 2017 Go to the documentation of gitlab 0.1.1 Download gitlab 0.1.1 archive

All 11 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
11
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0 <1.23.0