gitlab 0.1.3

  • Installing
  • Versions
  • 46

GitLab API

build status

This is a dart library to communicate with the GitLab API v3.

This is still work in progress. We are happy about Merge Requests!

This library is already in production use, but it is missing a lot of calls and properties.

The calls that are present should be safe to use.

There are still tests missing for a lot of resources though.


Simply add it to your project as a dependency:

  gitlab: any


For the full documentation, and usage, please refer to the documentation.




  • Add labels to the merge requests
  • Add tests for merge requests


  • Introduce commit.createdAt


  • Add proper testing and refactor code base a bit


First version.

Introduces basic commands and most of the properties of the most important entities

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  gitlab: "^0.1.3"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:gitlab/gitlab.dart';
Version Uploaded Documentation Archive
0.2.3 Jul 5, 2017 Go to the documentation of gitlab 0.2.3 Download gitlab 0.2.3 archive
0.2.2 Jun 26, 2017 Go to the documentation of gitlab 0.2.2 Download gitlab 0.2.2 archive
0.2.1 May 2, 2017 Go to the documentation of gitlab 0.2.1 Download gitlab 0.2.1 archive
0.2.0 May 2, 2017 Go to the documentation of gitlab 0.2.0 Download gitlab 0.2.0 archive
0.1.3 Feb 28, 2017 Go to the documentation of gitlab 0.1.3 Download gitlab 0.1.3 archive
0.1.2 Feb 15, 2017 Go to the documentation of gitlab 0.1.2 Download gitlab 0.1.2 archive
0.1.1 Feb 15, 2017 Go to the documentation of gitlab 0.1.1 Download gitlab 0.1.1 archive
0.1.0 Feb 15, 2017 Go to the documentation of gitlab 0.1.0 Download gitlab 0.1.0 archive


We analyzed this package on Jun 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
14 / 100
Code health derived from static analysis. [more]
98 / 100
Reflects how tidy and up-to-date the package is. [more]
50 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.


  • Fix dependencies in pubspec.yaml.

    Running pub upgrade failed with the following output:

    ERR: The current Dart SDK version is 2.0.0-dev.63.0.
     Because gitlab requires SDK version >=1.21.0 <1.23.0, version solving failed.
  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Fix dependencies in pubspec.yaml.

  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Package is getting outdated.

    The package was released 68 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 9 hints.

    Run dartfmt to format lib/gitlab.dart.

    Run dartfmt to format lib/src/builds.dart.

    Similar analysis of the following files failed:

    • lib/src/commits.dart (hint)
    • lib/src/http_client.dart (hint)
    • lib/src/issues.dart (hint)
    • lib/src/merge_requests.dart (hint)
    • lib/src/projects.dart (hint)
    • lib/src/snippets.dart (hint)
    • lib/src/utils.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use gitlab.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0 <1.23.0