This is a dart library to communicate with the GitLab API v4.
This is still work in progress. We are happy about Merge Requests!
This library is already in production use, but it is missing a lot of calls and properties.
The calls that are present should be safe to use.
There are still tests missing for a lot of resources though.
Simply add it to your project as a dependency:
dependencies: gitlab: any
For the full documentation, and usage, please refer to the documentation.
intldependency to include
Introduces basic commands and most of the properties of the most important entities
Add this to your package's pubspec.yaml file:
dependencies: gitlab: ^0.2.3
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.4.1||Aug 23, 2018|
|0.4.0||Aug 17, 2018|
|0.3.0||Aug 8, 2018|
|0.2.3||Jul 5, 2017|
|0.2.2||Jun 26, 2017|
|0.2.1||May 2, 2017|
|0.2.0||May 2, 2017|
|0.1.3||Feb 28, 2017|
|0.1.2||Feb 15, 2017|
|0.1.1||Feb 15, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc failed. (-10 points)
dartdoc runs without any issues.
|Dart SDK||>=1.21.0 <2.0.0|