gitter 0.1.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 88

gitter

A Dart library to communicate with the Gitter API

Usage

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.1.1

  • remove jaguar_serializer

0.1.1

  • update jaguar_serializer to 0.3.7

0.1.0

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gitter: "^0.1.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:gitter/gitter.dart';
  
Version Uploaded Documentation Archive
0.1.2 Jul 17, 2017 Go to the documentation of gitter 0.1.2 Download gitter 0.1.2 archive
0.1.1 Jun 8, 2017 Go to the documentation of gitter 0.1.1 Download gitter 0.1.1 archive
0.1.0+1 Jun 1, 2017 Go to the documentation of gitter 0.1.0+1 Download gitter 0.1.0+1 archive
0.1.0 Jun 1, 2017 Go to the documentation of gitter 0.1.0 Download gitter 0.1.0 archive

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
78 / 100
Health:
Code health derived from static analysis. [more]
97 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
88
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:gitter/gitter.dart.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 22 hints.

    Run dartfmt to format lib/src/api.dart.

    Run dartfmt to format lib/src/faye.dart.

    Similar analysis of the following files failed:

    • lib/src/models/group.dart (hint)
    • lib/src/models/issue.dart (hint)
    • lib/src/models/mention.dart (hint)
    • lib/src/models/message.dart (hint)
    • lib/src/models/room.dart (hint)
    • lib/src/models/token.dart (hint)
    • lib/src/models/user.dart (hint)
    • lib/src/oauth/src/api.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use gitter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
http ^0.11.3+13 0.11.3+16
Transitive dependencies
async 2.0.7
charcode 1.1.1
collection 1.14.10
http_parser 3.1.2
path 1.6.0
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5