globbing 0.1.20

  • README.md
  • Installing
  • Versions
  • 30

globbing

Globbing is a library for pattern matching based on wildcard characters.

Real examples of practical usage of globbing package can be found in file_utils package.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  globbing: "^0.1.20"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:globbing/globbing.dart';
        
Version Uploaded Documentation Archive
0.1.20 Sep 11, 2014 failed Download globbing 0.1.20 archive
0.1.19 Jul 30, 2014 failed Download globbing 0.1.19 archive
0.1.18 May 27, 2014 failed Download globbing 0.1.18 archive
0.1.17 May 8, 2014 failed Download globbing 0.1.17 archive
0.1.16 May 8, 2014 failed Download globbing 0.1.16 archive
0.1.15 May 7, 2014 failed Download globbing 0.1.15 archive
0.1.14 May 7, 2014 failed Download globbing 0.1.14 archive
0.1.12 May 6, 2014 failed Download globbing 0.1.12 archive
0.1.11 May 5, 2014 Go to the documentation of globbing 0.1.11 Download globbing 0.1.11 archive
0.1.10 May 3, 2014 Go to the documentation of globbing 0.1.10 Download globbing 0.1.10 archive

All 26 versions...

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
6 / 100
Health:
Code health derived from static analysis. [more]
91 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
30
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Error(s) in lib/glob_lister.dart: Target of URI doesn't exist: 'package:path/path.dart'.

Suggestions

  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Error(s) in lib/glob_lister.dart: Target of URI doesn't exist: 'package:path/path.dart'.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 3 errors 6 hints.

    Make sure that the imported libraries are not in conflict. Error(s) in lib/glob_lister.dart: Target of URI doesn't exist: 'package:path/path.dart'.

    Strong-mode analysis of lib/src/glob_parser.dart failed with the following error:

    line: 275 col: 3
    Invalid override. The type of 'GlobNodeSegments._nodes=' ('(List<GlobNodeSegment>) → void') isn't a subtype of 'GlobNodeCollection._nodes=' ('(List<GlobNode>) → void').

    Similar analysis of the following files failed:

    • lib/src/glob_filter.dart (hint)
    • lib/src/glob_lister.dart (hint)
    • lib/src/globbing.dart (hint)
  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use globbing.dart.

Dependencies

Package Constraint Resolved Available
Dev dependencies
path any
unittest any