glutils 0.0.1

  • README.md
  • Installing
  • Versions
  • 0

WebGL utility library

This is not a framework. I like using WebGL as direct as possible myself. This library helps to get some tedious tasks done more easily including compiling shaders and linking buffers.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  glutils: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:glutils/glutils.dart';
  
Version Uploaded Documentation Archive
0.0.1 Jun 30, 2017 Go to the documentation of glutils 0.0.1 Download glutils 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0