google_maps 3.1.0

Dart Google Maps

This project is a library to use Google Maps JavaScript API v3 from dart scripts.

Usage

To use this library in your code :

  • add a dependency in your pubspec.yaml :
dependencies:
  google_maps: ">=2.0.0 <3.0.0"
  • add import in your dart code :
import 'package:google_maps/google_maps.dart';
  • Include the Maps API JavaScript using a script tag.
<script src="https://maps.googleapis.com/maps/api/js?key=API_KEY"></script>

Please see the Google Maps JavaScript API v3 Getting Started guide for information about obtaining an API Key.

  • Include the js-interop script using a script tag just after packages/browser/dart.js.
<script src="packages/browser/dart.js"></script>

A very simple example :

import 'dart:html';

import 'package:google_maps/google_maps.dart';

void main() {
  final mapOptions = new MapOptions()
    ..zoom = 8
    ..center = new LatLng(-34.397, 150.644)
    ..mapTypeId = MapTypeId.ROADMAP
    ;
  final map = new GMap(querySelector("#map_canvas"), mapOptions);
}

Coverage

The library covers all Google Maps JavaScript API v3 and its Libraries. To use one or more Google Maps Library :

  • add import in your dart code :
import 'package:google_maps/google_maps_LIBRARY1.dart';
import 'package:google_maps/google_maps_LIBRARY2.dart';
  • Include the Maps API JavaScript using a script tag.
<script src="http://maps.googleapis.com/maps/api/js?sensor=false&libraries=LIBRARY1,LIBRARY2"></script>

Examples

Examples found at https://google-developers.appspot.com/maps/documentation/javascript/examples/ are available in a dart version in example directory.

License

Apache 2.0

v3.1.0 (2015-12-17)

  • support of the Google Maps API 3.22

v3.0.2 (2015-06-16)

v3.0.1 (2015-06-12)

v3.0.0 (2015-06-05)

  • support of the Google Maps API 3.20
  • migration to js_wrapping-0.2.0

Semantic Version Conventions

http://semver.org/

  • Stable: All even numbered minor versions are considered API stable: i.e.: v1.0.x, v1.2.x, and so on.
  • Development: All odd numbered minor versions are considered API unstable: i.e.: v0.9.x, v1.1.x, and so on.

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  google_maps: 

2. Install it

You can install packages from the command line:

$ pub get

Alternatively, your editor might support pub. Check the docs for your editor to learn more.

About

With that package you will be able to use Google Maps JavaScript API from Dart scripts.

Author

Email alexandre.ardhuin@gmail.com Alexandre Ardhuin

Homepage

github.com/a14n/dart-google-maps

Documentation

www.dartdocs.org/documentation/google_maps/3.1.0/

Source code (hyperlinked)

www.crossdart.info/p/google_maps/3.1.0/

Uploader

alexandre.ardhuin@gmail.com

Share