google_maps_markerclusterer 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 60

google_maps_markerclusterer

Dart wrapper for Google Maps MarkerClusterer utility library. https://github.com/googlemaps/v3-utility-library/tree/master/markerclusterer

Thanks to @a14n for https://github.com/a14n/dart-google-maps and https://github.com/a14n/dart-js-wrapping

Changelog

0.1.1

  • Align with latest version

0.1.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  google_maps_markerclusterer: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:google_maps_markerclusterer/markerclusterer.dart';
  
Version Uploaded Documentation Archive
0.1.1 Apr 5, 2018 Go to the documentation of google_maps_markerclusterer 0.1.1 Download google_maps_markerclusterer 0.1.1 archive
0.1.0 Sep 12, 2017 Go to the documentation of google_maps_markerclusterer 0.1.0 Download google_maps_markerclusterer 0.1.0 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
21 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
60
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Run dartfmt to format lib/src/markerclusterer.dart.

    Strong-mode analysis of lib/src/markerclusterer.g.dart gave the following hint:

    line: 24 col: 7
    The top level variable '__codec5' isn't used.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use google_maps_markerclusterer.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
google_maps ^3.2.2 3.2.4
js_wrapping ^0.4.1 0.4.9
Transitive dependencies
func 1.0.0
meta 1.1.5
Dev dependencies
browser ^0.10.0
build_runner ^0.4.0+3
html ^0.12.0
js_wrapping_generator ^0.4.1
source_gen ^0.7.1
test ^0.12.0