google_places_picker 0.0.9

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 83

google_places_picker

Google Place Picker and Autocomplete for Flutter

Getting Started

Setting up

  1. Go to your AndroidManifest.xml at android/app/src/main and add the following in between the application opening and closing tag, replacing YOUR_API_KEY with your api key, which you can get from the Google Developer Console:
<meta-data
      android:name="com.google.android.geo.API_KEY"
      android:value="YOUR_API_KEY"/>
  1. Go to AppDelegate.m/.swift in ios/Runner, and in the didFinishLaunchingWithOptions method add the following lines:
  • Swift

GMSPlacesClient.provideApiKey("YOUR_API_KEY")
GMSSServices.provideApiKey("YOUR_API_KEY")
  • Objective-C
[GMSPlacesClient provideApiKey:@"YOUR_API_KEY"];
[GMSServices provideApiKey:@"YOUR_API_KEY"];

Usage

You can use the plugin via the showPlacePicker and showAutocomplete methods. The showAutocomplete method takes a PlaceAutocompleteMode paramater to know whether to display the fullscreen or the overlay control on Android (it has no effect on iOS). Both methods return a Place object with the following properties:

  • name
  • id
  • address
  • latitude
  • longitude

[0.0.9] - 2018-11-03

  • Fixed more Android build errors

[0.0.8] - 2018-11-03

  • Updated Kotlin version

[0.0.7] - 2018-11-03

  • Fixed compile error on Flutter 0.10.x

[0.0.6] - 2018-09-21

  • Fixed scenario where random point selected in the Place Picker would crash the app due to no address

[0.0.5] - 2018-09-03

  • Updated sdk dependency for flutter 0.6.0

example/README.md

google_places_picker_example

Demonstrates how to use the google_places_picker plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  google_places_picker: ^0.0.9

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:google_places_picker/google_places_picker.dart';
  
Version Uploaded Documentation Archive
0.0.9 Nov 3, 2018 Go to the documentation of google_places_picker 0.0.9 Download google_places_picker 0.0.9 archive
0.0.8 Nov 3, 2018 Go to the documentation of google_places_picker 0.0.8 Download google_places_picker 0.0.8 archive
0.0.7 Nov 3, 2018 Go to the documentation of google_places_picker 0.0.7 Download google_places_picker 0.0.7 archive
0.0.6 Sep 21, 2018 Go to the documentation of google_places_picker 0.0.6 Download google_places_picker 0.0.6 archive
0.0.5 Sep 3, 2018 Go to the documentation of google_places_picker 0.0.5 Download google_places_picker 0.0.5 archive
0.0.4 May 20, 2018 Go to the documentation of google_places_picker 0.0.4 Download google_places_picker 0.0.4 archive
0.0.3 May 20, 2018 Go to the documentation of google_places_picker 0.0.3 Download google_places_picker 0.0.3 archive
0.0.2 May 19, 2018 Go to the documentation of google_places_picker 0.0.2 Download google_places_picker 0.0.2 archive
0.0.1 May 19, 2018 Go to the documentation of google_places_picker 0.0.1 Download google_places_picker 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
84
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
83
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-10 points)

19 out of 19 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8