googleapis_auth_default_credentials 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

googleapis_auth_default_credentials

This package provides an implementation of application default credentials for Dart.

The Application Default Credentials provide a simple way to get authorization credentials for use in calling Google APIs.

They are best suited for cases when the call needs to have the same identity and authorization level for the application independent of the user. This is the recommended approach to authorize calls to Cloud APIs, particularly when you're building an application that uses Google Compute Engine.

Example

import 'package:http/http.dart';
import 'package:googleapis_auth_default_credentials/googleapis_auth_default_credentials.dart';
import 'package:googleapis_auth/auth_io.dart';
import 'package:googleapis/storage/v1.dart';

const _SCOPES = const [StorageApi.DevstorageReadOnlyScope];

main() async {
  Client client = new Client();
  AccessCredentials credentials = await obtainDefaultAccessCredentials(_SCOPES, client);
  AuthClient authClient = authenticatedClient(client, credentials);
  final storage = new StorageApi(authClient);
  final buckets = await storage.buckets.list('test');
  print(buckets.toJson());
  client.close();
}

Changelog

0.1.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  googleapis_auth_default_credentials: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:googleapis_auth_default_credentials/googleapis_auth_default_credentials.dart';
  
Version Uploaded Documentation Archive
0.1.0 Oct 6, 2016 Go to the documentation of googleapis_auth_default_credentials 0.1.0 Download googleapis_auth_default_credentials 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0