gpmx 0.2.1

  • README.md
  • Installing
  • Versions
  • 36

gpmx.dart

Build Status License Node

Git Package Manager, make you manage the repository easier

Features

  • [x] support Github, Gitlab, etc
  • [x] add, remove, clean, cache, list commands
  • [x] score, humanize, easier to manager
  • [ ] add repository in multi directories

Installation

// TODO

Requirement

  • dart

Supports

  • [ ] Windows
  • [x] Linux
  • [x] MacOS

Usage

gpmx -h

# print out

  Usage: gpmx <command> [options]

    Git Package Manager, make you manage the repository easier, Power by Dart

  Commands:
    list              display the all repo.
    add <repo>        clone repo into local dir.
    remove            remove a repo.
    clean             clean the temp/cache.
    runtime           print the program runtime, useful for submit a issue.
    relink            relink the base dir which contain repositories if you delete repository manually.
    import <dir>      register a repository to GPM.

  Options:
    -V, --version      print the current version
    -h, --help         print the help info about 

Config

this is a default config, it will be generated in ~/.gpmx by default

{
  "name": "gpmx",
  "base": "gpmx"
}
  • name: user name
  • base: the repositories base dir, all repository will be install in this dir

Example

gpmx add https://github.com/zeit/release.git
gpmx add https://github.com/axetroy/gpm.git
gpmx add https://github.com/axetroy/ymli.git

gpmx ls

# print out
github.com: 
  axetroy: 
    gpm:  /home/axetroy/gpmx/github.com/axetroy/gpm
    ymli: /home/axetroy/gpmx/github.com/axetroy/ymli
  zeit: 
    release: /home/axetroy/gpmx/github.com/zeit/release

Uninstall

// TODO

Contribute

git clone https://github.com/axetroy/gpm.dart.git
cd ./gpm.dart
pub get
dart ./bin/gpmx

You can flow Contribute Guide

License

The MIT License

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gpmx: "^0.2.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gpmx/gpmx.dart';
        
Version Uploaded Documentation Archive
0.2.1 Mar 6, 2017 Go to the documentation of gpmx 0.2.1 Download gpmx 0.2.1 archive
0.2.0 Mar 6, 2017 Go to the documentation of gpmx 0.2.0 Download gpmx 0.2.0 archive
0.1.0 Mar 1, 2017 Go to the documentation of gpmx 0.1.0 Download gpmx 0.1.0 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 16, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
76 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
64 / 100
Overall score:
Weighted score of the above. [more]
36

Platforms

Detected platforms: Flutter, other

Primary library: package:gpmx/gpmx.dart with components: io.

Suggestions

  • Fix lib/commands/add.dart.

    Strong-mode analysis of lib/commands/add.dart failed with the following error:

    line: 69 col: 34
    The operator '[]' isn't defined for the class 'Object'.

  • Fix lib/commands/list.dart.

    Strong-mode analysis of lib/commands/list.dart failed with the following error:

    line: 12 col: 34
    The operator '[]' isn't defined for the class 'Object'.

  • Fix further 2 Dart files.

    Similar analysis of the following files failed:

    • lib/commands/remove.dart
    • lib/commands/relink.dart
  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 3 error(s) and 0 warning(s).

  • Use constrained dependencies.

    The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: escli, git_url_parse.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use gpmx.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
escli 0.0.1
git_url_parse 0.1.0
log >=0.0.6 <1.0.0 0.0.6
path >=1.4.1 <2.0.0 1.5.1
prompt >=0.1.7 <0.2.0 0.1.7
Transitive dependencies
ansicolor 0.0.9
dye 0.0.2
ee 0.0.3
mock 0.11.0+4 0.12.0
stack_trace 1.9.2
supports_color 0.1.1
unittest 0.11.7 0.12.4+1
url_parse 0.1.0
when 0.2.0