gradient_bottom_navigation_bar 1.0.0+4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 86

Gradient Bottom Navigation Bar #

pub package

This package allows you to add a gradient to the standard Material Bottom Navigation Bar.

Getting Started #

First, add this line in your project's pubspec.yaml

dependencies:
  ...
  gradient_bottom_navigation_bar: ^1.0.0+4

For help getting started with Flutter, view the online documentation.

Usage examples #

Import gradient_bottom_navigation_bar.dart in your desired class

import 'package:gradient_bottom_navigation_bar/gradient_bottom_navigation_bar.dart';

...

Basic implementation #

@override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Example'),
      ),
      body: Center(
        child: _widgetOptions.elementAt(_selectedIndex),
      ),
      bottomNavigationBar: GradientBottomNavigationBar(
        backgroundColorStart: Colors.purple,
        backgroundColorEnd: Colors.deepOrange,
        items: <BottomNavigationBarItem>[
          BottomNavigationBarItem(icon: Icon(Icons.home), title: Text('Home')),
          BottomNavigationBarItem(icon: Icon(Icons.business), title: Text('Business')),
          BottomNavigationBarItem(icon: Icon(Icons.school), title: Text('School')),
        ],
        currentIndex: _selectedIndex,
        onTap: _onItemTapped,
      ),
    );
  }

You can also check the example for additional information.

Screenshots #

Example

[1.0.0+4] - 02/03/2019

  • README changes

[1.0.0+3] - 02/03/2019.

  • Description updated with a better explanation.

[1.0.0+2] - 01/17/2019.

  • Dartdoc generation fix.

[1.0.0+1] - 01/16/2019.

  • Minor changes in docs.

[1.0.0] - 01/11/2019.

  • Support for Linear Gradients.

example/README.md

example #

Example of GradientBottomNavigationBar's functionality.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gradient_bottom_navigation_bar: ^1.0.0+4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gradient_bottom_navigation_bar/gradient_bottom_navigation_bar.dart';
  
Version Uploaded Documentation Archive
1.0.0+4 Feb 3, 2019 Go to the documentation of gradient_bottom_navigation_bar 1.0.0+4 Download gradient_bottom_navigation_bar 1.0.0+4 archive
1.0.0+3 Feb 3, 2019 Go to the documentation of gradient_bottom_navigation_bar 1.0.0+3 Download gradient_bottom_navigation_bar 1.0.0+3 archive
1.0.0+2 Jan 17, 2019 Go to the documentation of gradient_bottom_navigation_bar 1.0.0+2 Download gradient_bottom_navigation_bar 1.0.0+2 archive
1.0.0+1 Jan 16, 2019 Go to the documentation of gradient_bottom_navigation_bar 1.0.0+1 Download gradient_bottom_navigation_bar 1.0.0+1 archive
1.0.0 Jan 10, 2019 Go to the documentation of gradient_bottom_navigation_bar 1.0.0 Download gradient_bottom_navigation_bar 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
72
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
86
Learn more about scoring.

We analyzed this package on Apr 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test