grakn 2.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 66

grakn-dart

A Grakn REST API connector for the Grakn hyper-relational graph database.

Tested with Grakn 1.0 and 1.1

Usage

A simple usage example:

import "dart:convert";
import 'package:grakn/grakn.dart';

main() async {
    Grakn grakn = new Grakn();
    String rawString = await grakn.execute("match \$x isa thing; get;");
    List rawList = JSON.decode(rawString);
    print('awesome: $rawList');
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

2.0.1

  • documentation

2.0

  • Fixes an encoding issue

1.1

  • Fixes an issue when the result of the server is bigger than 32k.

1.0

  • Initial release. Tested with Grakn 1.0

example/grakn_example.dart

import "dart:convert";
import 'package:grakn/grakn.dart';

main() async {
  Grakn grakn = new Grakn();
  String query = "match \$x isa thing; get;";
  String rawString = await grakn.execute(query);
  List rawList = JSON.decode(rawString);
  print('awesome: $rawList');
}

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  grakn: "^2.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:grakn/grakn.dart';
        
Version Uploaded Documentation Archive
2.0.1 Mar 5, 2018 Go to the documentation of grakn 2.0.1 Download grakn 2.0.1 archive
2.0.0 Feb 27, 2018 Go to the documentation of grakn 2.0.0 Download grakn 2.0.0 archive
1.1.1 Feb 16, 2018 Go to the documentation of grakn 1.1.1 Download grakn 1.1.1 archive
1.1.0 Feb 16, 2018 Go to the documentation of grakn 1.1.0 Download grakn 1.1.0 archive
1.0.0 Feb 7, 2018 Go to the documentation of grakn 1.0.0 Download grakn 1.0.0 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
35 / 100
Health:
Code health derived from static analysis. [more]
96 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
66
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:grakn/grakn.dart with components: io.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Run dartfmt to format lib/src/grakn_base.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
logging ^0.11.3+1 0.11.3+1
Dev dependencies
test ^0.12.0