graphql_fetch_generator 0.0.3

  • Installing
  • Versions
  • 0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  graphql_fetch_generator: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:graphql_fetch_generator/graphql_fetch_generator.dart';
  
Version Uploaded Documentation Archive
0.0.3 Nov 23, 2017 Go to the documentation of graphql_fetch_generator 0.0.3 Download graphql_fetch_generator 0.0.3 archive
0.0.2 Nov 20, 2017 Go to the documentation of graphql_fetch_generator 0.0.2 Download graphql_fetch_generator 0.0.2 archive
0.0.1 Nov 20, 2017 Go to the documentation of graphql_fetch_generator 0.0.1 Download graphql_fetch_generator 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because graphql_fetch_generator depends on json_object >=1.0.4 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/action.dart.

Run dartfmt to format lib/action.dart.

Format lib/graphql_fetch_generator.dart.

Run dartfmt to format lib/graphql_fetch_generator.dart.

Format lib/src/BaseTypes.dart.

Run dartfmt to format lib/src/BaseTypes.dart.

Fix additional 8 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/Fragment.dart (Run dartfmt to format lib/src/Fragment.dart.)
  • lib/src/GraphqlSchema.dart (Run dartfmt to format lib/src/GraphqlSchema.dart.)
  • lib/src/GraphqlSetting.dart (Run dartfmt to format lib/src/GraphqlSetting.dart.)
  • lib/src/InputTypes.dart (Run dartfmt to format lib/src/InputTypes.dart.)
  • lib/src/Operation.dart (Run dartfmt to format lib/src/Operation.dart.)
  • lib/src/QueryTypes.dart (Run dartfmt to format lib/src/QueryTypes.dart.)
  • lib/src/generator.dart (Run dartfmt to format lib/src/generator.dart.)
  • lib/transformer.dart (Run dartfmt to format lib/transformer.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain README.md. (-30 points)

Readme should inform others about your project, what it does, and how they can use it.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use graphql_fetch_generator.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-6.03 points)

The package was released 55 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <3.0.0