greencat 0.1.4

  • Installing
  • Versions
  • 76


A port of Redux to Dart, including Redux Thunk. API and conventions are preserved as much as possible and only changed to idiomatic Dart. This is work in progress and might introduce backward incompatible changes, though it is avoided.


Examples of usage are provided with AngularDart 2, Flutter and Butterfly.

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  greencat: "^0.1.4"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:greencat/greencat.dart';
Version Uploaded Documentation Archive
0.1.4 Feb 20, 2018 Go to the documentation of greencat 0.1.4 Download greencat 0.1.4 archive
0.0.6 Sep 27, 2017 Go to the documentation of greencat 0.0.6 Download greencat 0.0.6 archive
0.0.5 Sep 27, 2017 Go to the documentation of greencat 0.0.5 Download greencat 0.0.5 archive
0.0.4 May 14, 2017 Go to the documentation of greencat 0.0.4 Download greencat 0.0.4 archive
0.0.2 Feb 11, 2017 Go to the documentation of greencat 0.0.2 Download greencat 0.0.2 archive
0.0.1 Oct 22, 2016 Go to the documentation of greencat 0.0.1 Download greencat 0.0.1 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
52 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:greencat/greencat.dart.


  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use greencat.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0
logging >=0.11.3 <0.12.0 0.11.3+1
tuple >=1.0.1 <2.0.0 1.0.1
Transitive dependencies
quiver_hashcode 1.0.0
Dev dependencies
test >=0.12.0 <0.13.0