greencat 0.1.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 7

greencat

A port of Redux to Dart, including Redux Thunk. API and conventions are preserved as much as possible and only changed to idiomatic Dart. This is work in progress and might introduce backward incompatible changes, though it is avoided.

Usage

Examples of usage are provided with AngularDart 2, Flutter and Butterfly.

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  greencat: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:greencat/greencat.dart';
  
Version Uploaded Documentation Archive
0.1.4 Feb 20, 2018 Go to the documentation of greencat 0.1.4 Download greencat 0.1.4 archive
0.0.6 Sep 27, 2017 Go to the documentation of greencat 0.0.6 Download greencat 0.0.6 archive
0.0.5 Sep 27, 2017 Go to the documentation of greencat 0.0.5 Download greencat 0.0.5 archive
0.0.4 May 14, 2017 Go to the documentation of greencat 0.0.4 Download greencat 0.0.4 archive
0.0.2 Feb 11, 2017 Go to the documentation of greencat 0.0.2 Download greencat 0.0.2 archive
0.0.1 Oct 22, 2016 Go to the documentation of greencat 0.0.1 Download greencat 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
7
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0