grizzly_array 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new40

grizzly_array

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage

A simple usage example:

import 'package:grizzly_array/grizzly_array.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.3

  • Do not inherit from Iterable

0.0.1

  • Bool1D
  • Double1D
  • Int1D
  • String1D
  • Bool2D
  • Double2D
  • Int2D
  • String2D

example/grizzly_array_example.dart

import 'package:grizzly_array/grizzly_array.dart';

main() {
  final v = new Double2D([
    [1.0, 2.0, 3.0],
    [4.0, 5.0, 6.0],
    [7.0, 8.0, 9.0],
  ]);
  print(v);
}

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  grizzly_array: "^0.0.3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:grizzly_array/grizzly_array.dart';
        
Version Uploaded Documentation Archive
0.0.3 Jan 28, 2018 Go to the documentation of grizzly_array 0.0.3 Download grizzly_array 0.0.3 archive
0.0.1 Jan 28, 2018 Go to the documentation of grizzly_array 0.0.1 Download grizzly_array 0.0.1 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 16, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
77 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85 / 100
Overall score:
Weighted score of the above. [more]
40

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:grizzly_array/grizzly_array.dart.

Suggestions

  • Fix lib/src/array2d/string/string_array2d.dart.

    Strong-mode analysis of lib/src/array2d/string/string_array2d.dart failed with the following error:

    line: 3 col: 7
    Missing concrete implementation of 'Array2DView.unique'.

  • Fix lib/src/array2d/string/string_view_array2d.dart.

    Strong-mode analysis of lib/src/array2d/string/string_view_array2d.dart failed with the following error:

    line: 3 col: 7
    Missing concrete implementation of 'Array2DView.unique'.

  • Fix further 26 Dart files.

    Similar analysis of the following files failed:

    • lib/src/array2d/string/string_fix_array2d.dart
    • lib/src/array2d/string/string_axis.dart
    • lib/src/array2d/bool/bool_axis.dart
    • lib/src/array2d/bool/bool_array2d.dart
    • lib/src/array2d/bool/bool_view_array2d.dart
    • lib/src/array2d/bool/bool_fix_array2d.dart
    • lib/src/array2d/int/int_view_array2d.dart
    • lib/src/array2d/int/int_array2d.dart
    • lib/src/array2d/int/int_fix_array2d.dart
    • lib/src/array2d/int/int_axis.dart
    • lib/src/array2d/double/double_fix_array2d.dart
    • lib/src/array2d/double/double_array2d.dart
    • lib/src/array2d/double/double_view_array2d.dart
    • lib/src/array2d/double/double_axis.dart
    • lib/src/array/string/string_array.dart
    • lib/src/array/string/string_view_array.dart
    • lib/src/array/string/string_fix_array.dart
    • lib/src/array/bool/bool_view_array.dart
    • lib/src/array/bool/bool_array.dart
    • lib/src/array/bool/bool_fix_array.dart
    • lib/src/array/int/int_fix_array.dart
    • lib/src/array/int/int_view_array.dart
    • lib/src/array/int/int_array.dart
    • lib/src/array/double/double_array.dart
    • lib/src/array/double/double_view_array.dart
    • lib/src/array/double/double_fix_array.dart
  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 3 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
grizzly_primitives ^0.0.7 0.0.9 0.1.0
grizzly_scales ^0.0.3-dev 0.0.3-dev
Transitive dependencies
meta 1.1.2
Dev dependencies
test ^0.12.0