grizzly_linalg 0.4.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 8

grizzly_linalg

Linear algebra

TODO

  • [ ] Singular values
  • [ ] Condition number
  • [ ] solve_triangular
  • [X] Determinant
  • [ ] Rank of matrix

Changelog

0.1.1-dev

  • SVD
  • LU solve

0.0.2

  • norm1 and norm2

0.0.1

  • LU, QR, SVD matrix decomposition
  • Gradient descent for least square estimation

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  grizzly_linalg: ^0.4.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:grizzly_linalg/grizzly_linalg.dart';
  
Version Uploaded Documentation Archive
0.4.2 May 29, 2018 Go to the documentation of grizzly_linalg 0.4.2 Download grizzly_linalg 0.4.2 archive
0.4.1 May 29, 2018 Go to the documentation of grizzly_linalg 0.4.1 Download grizzly_linalg 0.4.1 archive
0.1.1-dev Mar 30, 2018 Go to the documentation of grizzly_linalg 0.1.1-dev Download grizzly_linalg 0.1.1-dev archive
0.0.2-dev Oct 23, 2017 Go to the documentation of grizzly_linalg 0.0.2-dev Download grizzly_linalg 0.0.2-dev archive
0.0.1-dev Oct 21, 2017 Go to the documentation of grizzly_linalg 0.0.1-dev Download grizzly_linalg 0.0.1-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
8
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0