grizzly_stats 0.0.1-dev

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 49

grizzly_stats

Statistics library for Dart

  • [ ] Beta
  • [ ] Binomial
  • [ ] Cauchy
  • [ ] Chi-Square
  • [ ] Exponential
  • [ ] Gamma
  • [ ] Normal
  • [ ] Pareto
  • [ ] Student's T
  • [ ] Uniform
  • [ ] Weibull
  • [ ] Beta
  • [ ] Logistic
  • [ ] Log-Normal
  • [ ] F
  • [ ] Laplace

References

  • Porting from Golang library prob

Changelog

0.0.1

  • Distributions incomplete
  • Uniform, standard normal, normal, exponential and standard exponential samplers

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  grizzly_stats: "^0.0.1-dev"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:grizzly_stats/grizzly_stats.dart';
        
Version Uploaded Documentation Archive
0.0.1-dev Oct 31, 2017 Go to the documentation of grizzly_stats 0.0.1-dev Download grizzly_stats 0.0.1-dev archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
93 / 100
Overall score:
Weighted score of the above. [more]
49

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:grizzly_stats/grizzly_stats.dart.

Suggestions

  • Use constrained dependencies.

    The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: grizzly_scales, grizzly_series.

  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use grizzly_stats.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
grizzly_scales 0.0.3-dev
grizzly_series 0.0.23-dev
Transitive dependencies
grizzly_primitives 0.0.9
meta 1.1.2
Dev dependencies
test ^0.12.0