gtag_interop 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new72

Gtag Interop for Dart

Runtime Release License Coverage Build

Global site tag (gtag.js) interoperability for Dart.

Resources

License

Gtag Interop for Dart is distributed under the MIT License.

Changelog

Version 0.1.0

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gtag_interop: "^0.1.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:gtag_interop/gtag_interop.dart';
  
Version Uploaded Documentation Archive
0.1.0 Jun 25, 2018 Go to the documentation of gtag_interop 0.1.0 Download gtag_interop 0.1.0 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
58 / 100
Health:
Code health derived from static analysis. [more]
97 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72 / 100
Overall score:
Weighted score of the above. [more]
72
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Suggestions

  • Fix dependencies in pubspec.yaml.

    Running pub upgrade failed with the following output:

    ERR: The current Dart SDK version is 2.0.0-dev.63.0.
     
     Because gtag_interop requires SDK version >=2.0.0-dev.64 <2.0.0, version solving failed.
    
  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Fix dependencies in pubspec.yaml.

  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 7 hints.

    Run dartfmt to format lib/src/html/analytics.dart.

    Run dartfmt to format lib/src/html/service.dart.

    Similar analysis of the following files failed:

    • lib/src/js/command.dart (hint)
    • lib/src/js/data.dart (hint)
    • lib/src/js/event.dart (hint)
    • lib/src/js/gtag.dart (hint)
    • lib/src/js/parameters.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use gtag_interop.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.64 <2.0.0