guppy_dart 0.0.3+1

  • README.md
  • Installing
  • Versions
  • 36

Guppy equation editor for Dart

See: https://github.com/daniel3735928559/guppy.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  guppy_dart: "^0.0.3+1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:guppy_dart/guppy_dart.dart';
  
Version Uploaded Documentation Archive
0.0.3+1 Nov 11, 2016 Go to the documentation of guppy_dart 0.0.3+1 Download guppy_dart 0.0.3+1 archive
0.0.3 Nov 5, 2016 Go to the documentation of guppy_dart 0.0.3 Download guppy_dart 0.0.3 archive
0.0.2 Nov 3, 2016 Go to the documentation of guppy_dart 0.0.2 Download guppy_dart 0.0.2 archive
0.0.1+2 Nov 3, 2016 Go to the documentation of guppy_dart 0.0.1+2 Download guppy_dart 0.0.1+2 archive
0.0.1+1 Nov 3, 2016 Go to the documentation of guppy_dart 0.0.1+1 Download guppy_dart 0.0.1+1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
32 / 100
Overall score:
Weighted score of the above. [more]
36
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:guppy_dart/guppy_dart.dart with components: html, js.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Package is getting outdated.

    The package was released 83 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use guppy_dart.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
browser ^0.10.0+2 0.10.0+3
js ^0.6.1 0.6.1