guppy_dart 0.0.3+1

  • Installing
  • Versions
  • 42

Guppy equation editor for Dart


1. Depend on it

Add this to your package's pubspec.yaml file:

  guppy_dart: "^0.0.3+1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:guppy_dart/guppy_dart.dart';
Version Uploaded Documentation Archive
0.0.3+1 Nov 11, 2016 Go to the documentation of guppy_dart 0.0.3+1 Download guppy_dart 0.0.3+1 archive
0.0.3 Nov 5, 2016 Go to the documentation of guppy_dart 0.0.3 Download guppy_dart 0.0.3 archive
0.0.2 Nov 3, 2016 Go to the documentation of guppy_dart 0.0.2 Download guppy_dart 0.0.2 archive
0.0.1+2 Nov 3, 2016 Go to the documentation of guppy_dart 0.0.1+2 Download guppy_dart 0.0.1+2 archive
0.0.1+1 Nov 3, 2016 Go to the documentation of guppy_dart 0.0.1+1 Download guppy_dart 0.0.1+1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
61 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: web

Primary library: package:guppy_dart/guppy_dart.dart with components: html, js.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use guppy_dart.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
browser ^0.10.0+2 0.10.0+2
js ^0.6.1 0.6.1