Detect and create Haikus
final poem = ''' This is my long poem. It is too long for haiku, because it's tail is quite large. '''; final haikuPoem = ''' An old silent pond... A frog jumps into the pond, splash! Silence again. '''; HaikuComposer composer = new HaikuComposer(); print(composer.isHaiku(poem)); // False; 19 syllables print(composer.isHaiku(haikuPoem)); // True
final haiku = composer.create(haikuPoem); print(haiku.firstLine); // ['An', 'old', 'silent', 'pond...']; print(haiku.secondLine); // ['A', 'frog', 'jumps', 'into', 'the', 'pond']; print(haiku.thirdLine); // ['splash!', 'Silence', 'again.'];
print(const HaikuFormatter().format(haiku)); // An old silent pond... // A frog jumps into the pond, // splash! Silence again.
Add this to your package's pubspec.yaml file:
dependencies: haiku: ^1.0.6
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.6||Oct 6, 2017|
|1.0.5||Oct 6, 2017|
|1.0.4||Oct 6, 2017|
|1.0.3||Oct 6, 2017|
|1.0.2||Oct 6, 2017|
|1.0.1||Oct 5, 2017|
|1.0.0||Oct 4, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.