handheld 2.0.0

  • README.md
  • Installing
  • Versions
  • 19

Handheld

Handheld was a experimental wrapper for PhoneGap that experiemented with mobile applications in Dart.

Handheld is not longer maintianed instead we recommend

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  handheld: "^2.0.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:handheld/handheld.dart';
        
Version Uploaded Documentation Archive
2.0.0 Aug 21, 2015 Go to the documentation of handheld 2.0.0 Download handheld 2.0.0 archive
1.2.1 Jul 11, 2013 Go to the documentation of handheld 1.2.1 Download handheld 1.2.1 archive
1.2.0 Jul 11, 2013 Go to the documentation of handheld 1.2.0 Download handheld 1.2.0 archive
1.0.5 Mar 23, 2013 Go to the documentation of handheld 1.0.5 Download handheld 1.0.5 archive

Analysis

This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Jan 21, 2018
  • Dart: 2.0.0-dev.15.0
  • pana: 0.10.0

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
64 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
19

Platforms

Detected platforms: unsure

Error(s) prevent platform classification.

Suggestions

  • Fix lib/handheld_builder.dart.

    Strong-mode analysis of lib/handheld_builder.dart failed with the following error:

    line: 10 col: 8
    Target of URI doesn't exist: 'package:log4dart/log4dart.dart'.

  • Fix lib/src/js/device_js.dart.

    Strong-mode analysis of lib/src/js/device_js.dart failed with the following error:

    line: 7 col: 7
    Missing concrete implementation of getter 'Device.camera'.

  • Fix further 4 Dart files.

    Similar analysis of the following files failed:

    • lib/src/js/device_accelerometer_js.dart
    • lib/src/handheld_mock_impl.dart
    • lib/src/handheld_js_impl.dart
    • lib/handheld.dart
  • Fix platform conflicts.

    Make sure none of the libraries use mutually exclusive dependendencies.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 3 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use handheld.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0
meta >=0.8.8 <0.9.0 0.8.8 1.1.2
Dev dependencies
test any