hashcash 1.0.0

  • README.md
  • Example
  • Installing
  • Versions
  • 29


Hashcash is a proof-of-work algorithm, which has been used as a denial-of-service counter measure technique in a number of systems.

A hashcash stamp constitutes a proof-of-work which takes a parameterizable amount of work to compute for the sender. The recipient (and indeed anyone as it is publicly auditable) can verify received hashcash stamps efficiently. Hashcash was invented by Adam Back in 1997

How to use it

Call HashCash.mint to generate a stamp and use HashCash.check to verify if this stamp is correct



update to crypto 1.1.1 for significant improvement


  • Initial version, created by Stagehand


// Copyright (c) 2015, Kevin Segaud. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import "package:hashcash/hashcash.dart";

main() {
  String stamp = HashCash.mint("segaud.kevin@gmail.com");
  print(HashCash.check(stamp, resource: "segaud.kevin@gmail.com"));

1. Depend on it

Add this to your package's pubspec.yaml file:

  hashcash: "^1.0.0"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:hashcash/hashcash.dart';
Version Uploaded Documentation Archive
1.0.0 May 11, 2016 Go to the documentation of hashcash 1.0.0 Download hashcash 1.0.0 archive
0.0.1 May 11, 2016 Go to the documentation of hashcash 0.0.1 Download hashcash 0.0.1 archive


We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
94 / 100
Reflects how tidy and up-to-date the package is. [more]
5 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:hashcash/hashcash.dart.


  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 6 hints.

    Strong-mode analysis of lib/src/hashcash.dart gave the following hint:

    line: 90 col: 40
    'onError' is deprecated and shouldn't be used.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
crypto >=1.1.1 <2.0.0 1.1.1 2.0.2+1
Transitive dependencies
charcode 1.1.1
collection 1.14.9
convert 1.1.1 2.0.1
typed_data 1.1.5
Dev dependencies
benchmark_harness any
test any