heaven 1.0.0-dev+3

  • README.md
  • Installing
  • Versions
  • 0

heaven

A client-side rendering library ideal for reactive SPA's.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  heaven: ^1.0.0-dev+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:heaven/heaven.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev+3 Oct 23, 2016 Go to the documentation of heaven 1.0.0-dev+3 Download heaven 1.0.0-dev+3 archive
1.0.0-dev+2 Oct 23, 2016 Go to the documentation of heaven 1.0.0-dev+2 Download heaven 1.0.0-dev+2 archive
1.0.0-dev+1 Oct 23, 2016 Go to the documentation of heaven 1.0.0-dev+1 Download heaven 1.0.0-dev+1 archive
1.0.0-dev Oct 13, 2016 Go to the documentation of heaven 1.0.0-dev Download heaven 1.0.0-dev archive
0.0.0-dev.1 Jun 18, 2016 Go to the documentation of heaven 0.0.0-dev.1 Download heaven 0.0.0-dev.1 archive
0.0.0-dev+2 Jun 18, 2016 Go to the documentation of heaven 0.0.0-dev+2 Download heaven 0.0.0-dev+2 archive
0.0.0-dev+1 Jun 18, 2016 Go to the documentation of heaven 0.0.0-dev+1 Download heaven 0.0.0-dev+1 archive
0.0.0-dev Jun 17, 2016 Go to the documentation of heaven 0.0.0-dev Download heaven 0.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because angel_framework >=0.0.0-dev.1 <1.1.3 requires SDK version <2.0.0 and angel_framework >=1.1.3 <2.0.0-alpha depends on container ^0.1.2, angel_framework >=0.0.0-dev.1 <2.0.0-alpha requires container ^0.1.2.
 So, because container >=0.1.1 requires SDK version >=1.8.0 <2.0.0 and heaven depends on angel_framework ^1.0.0-dev, version solving failed.

Health suggestions

Format lib/angel.dart.

Run dartfmt to format lib/angel.dart.

Format lib/dom.dart.

Run dartfmt to format lib/dom.dart.

Format lib/heaven.dart.

Run dartfmt to format lib/heaven.dart.

Fix additional 19 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/reactive.dart (Run dartfmt to format lib/reactive.dart.)
  • lib/reactive_dom.dart (Run dartfmt to format lib/reactive_dom.dart.)
  • lib/src/element.dart (Run dartfmt to format lib/src/element.dart.)
  • lib/src/renderable.dart (Run dartfmt to format lib/src/renderable.dart.)
  • lib/src/renderer.dart (Run dartfmt to format lib/src/renderer.dart.)
  • lib/src/string_renderer.dart (Run dartfmt to format lib/src/string_renderer.dart.)
  • lib/src/ui/a.dart (Run dartfmt to format lib/src/ui/a.dart.)
  • lib/src/ui/body.dart (Run dartfmt to format lib/src/ui/body.dart.)
  • lib/src/ui/h.dart (Run dartfmt to format lib/src/ui/h.dart.)
  • lib/src/ui/head.dart (Run dartfmt to format lib/src/ui/head.dart.)
  • lib/src/ui/i.dart (Run dartfmt to format lib/src/ui/i.dart.)
  • lib/src/ui/input.dart (Run dartfmt to format lib/src/ui/input.dart.)
  • lib/src/ui/link.dart (Run dartfmt to format lib/src/ui/link.dart.)
  • lib/src/ui/list.dart (Run dartfmt to format lib/src/ui/list.dart.)
  • lib/src/ui/meta.dart (Run dartfmt to format lib/src/ui/meta.dart.)
  • lib/src/ui/p.dart (Run dartfmt to format lib/src/ui/p.dart.)
  • lib/src/ui/title.dart (Run dartfmt to format lib/src/ui/title.dart.)
  • lib/src/zen.dart (Run dartfmt to format lib/src/zen.dart.)
  • lib/ui.dart (Run dartfmt to format lib/ui.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Add SDK constraint in pubspec.yaml. (-5 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is getting outdated. (-98.90 points)

The package was released 103 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use heaven.dart.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.