heaven 1.0.0-dev+3

  • README.md
  • Installing
  • Versions
  • 8

heaven #

A client-side rendering library ideal for reactive SPA's.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  heaven: ^1.0.0-dev+3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:heaven/heaven.dart';
  
Version Uploaded Documentation Archive
1.0.0-dev+3 Oct 23, 2016 Go to the documentation of heaven 1.0.0-dev+3 Download heaven 1.0.0-dev+3 archive
1.0.0-dev+2 Oct 23, 2016 Go to the documentation of heaven 1.0.0-dev+2 Download heaven 1.0.0-dev+2 archive
1.0.0-dev+1 Oct 23, 2016 Go to the documentation of heaven 1.0.0-dev+1 Download heaven 1.0.0-dev+1 archive
1.0.0-dev Oct 13, 2016 Go to the documentation of heaven 1.0.0-dev Download heaven 1.0.0-dev archive
0.0.0-dev.1 Jun 18, 2016 Go to the documentation of heaven 0.0.0-dev.1 Download heaven 0.0.0-dev.1 archive
0.0.0-dev+2 Jun 18, 2016 Go to the documentation of heaven 0.0.0-dev+2 Download heaven 0.0.0-dev+2 archive
0.0.0-dev+1 Jun 18, 2016 Go to the documentation of heaven 0.0.0-dev+1 Download heaven 0.0.0-dev+1 archive
0.0.0-dev Jun 17, 2016 Go to the documentation of heaven 0.0.0-dev Download heaven 0.0.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
8
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.