heron 0.1.1

  • README.md
  • Installing
  • Versions
  • 43

Heron

Heron is a static site generator written in Dart.

The two major features that are different from most of similar tools:

  • metadata (site configuration and page front matter) is inherited and sub-directories and articles may override specific details
  • programmable hooks to customize many aspect of the transformation pipeline

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  heron: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:heron/heron.dart';
  
Version Uploaded Documentation Archive
0.1.1 Jan 27, 2017 Go to the documentation of heron 0.1.1 Download heron 0.1.1 archive
0.1.0 Jan 24, 2017 Go to the documentation of heron 0.1.0 Download heron 0.1.0 archive
0.0.2 Jan 17, 2017 Go to the documentation of heron 0.0.2 Download heron 0.0.2 archive
0.0.1 Jan 15, 2017 Go to the documentation of heron 0.0.1 Download heron 0.0.1 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
12 / 100
Health:
Code health derived from static analysis. [more]
95 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
43 / 100
Overall score:
Weighted score of the above. [more]
43
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:heron/heron.dart with components: io, isolate.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 4 hints.

    Strong-mode analysis of lib/src/data.dart failed with the following error:

    line: 56 col: 16
    The argument type '(String, dynamic) → Null' can't be assigned to the parameter type '(dynamic, dynamic) → void'.

    Strong-mode analysis of lib/src/io_utils.dart gave the following hint:

    line: 98 col: 44
    'APPEND' is deprecated and shouldn't be used.

  • Package is getting outdated.

    The package was released 76 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use heron.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0
markdown ^0.11.2 0.11.4 2.0.1
mustache ^0.2.5 0.2.5+1 1.0.1
resource ^2.1.0 2.1.4
yaml ^2.1.12 2.1.14
Transitive dependencies
charcode 1.1.2
collection 1.14.10
path 1.6.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
test ^0.12.18