hexview 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

hexview

Pretty print byte array as hexadecimal view

Usage

Hex view a file

TODO

Hex view a buffer

TODO

Hex view a String

TODO

Changelog

0.0.4

  • Reorganisation of Hex
  • Added hex8List, hex16List, hex24List, hex32List

0.0.3

  • Expose Hex

0.0.2

  • toString for HexView16

0.0.1

  • HexView16 and Record16

example/hexview_example.dart

import 'dart:typed_data';
import 'package:hexview/hexview.dart';

main() {
	final nums = new List<int>.generate(125, (i) => i + 5);
	final data = new Uint8List.fromList(nums);
	final view = new HexView16(5, data);
	print(view.numRecords);

	print(view);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hexview: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hexview/hexview.dart';
  
Version Uploaded Documentation Archive
0.0.4 Nov 20, 2017 Go to the documentation of hexview 0.0.4 Download hexview 0.0.4 archive
0.0.3 Nov 20, 2017 Go to the documentation of hexview 0.0.3 Download hexview 0.0.3 archive
0.0.2 Nov 20, 2017 Go to the documentation of hexview 0.0.2 Download hexview 0.0.2 archive
0.0.1 Nov 19, 2017 Go to the documentation of hexview 0.0.1 Download hexview 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0