hi_sync 0.2.0

  • README.md
  • Example
  • Installing
  • Versions
  • 2

hi_sync

A simple library for backup of local files.

Usage

See example.dart.

If 'hi_sync_type1' file exist in directory then the files and subdirectories are not deleted.

Class

Constructor
  hiSync(String copypath, String backpath, List<String> options)
  options
  -log logfilename(full path)
  -logAppend ... log append
  -nocopy directory ... the directory doesn't copy.

Metohds
    int sync()
        return: 0 = no error, -1 = Exception, -2 = other error

Properties
    String copypath: path of orignal files
    String backpath: path of backup space

More Information

See homepage.

Change log

0.2.0 add nocopy option
0.1.2 bugfix : control file mode
0.1.1 add arguments parameter for logfile
0.1.0 add control file function
0.0.1 bugfix : delete blank directory
0.0.0 New Release

example/example.dart

import '../lib/hi_sync.dart';
// import 'package:hi_sync/hi_sync.dart';

void main(List<String> arguments) {

	print('start program');

	if (arguments.length <= 1) {
		print('baksync CopyDirectory BackDirectory');
	} else {
		hiSync bakSync = new hiSync(arguments[0], arguments[1]);
		print('Back up ' + arguments[0] + ' to ' + arguments[1]);
		print('Program end : ' + bakSync.sync().toString());
	}

	print('end program');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hi_sync: "^0.2.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:hi_sync/hi_sync.dart';
  
Version Uploaded Documentation Archive
0.2.0 Apr 19, 2014 Go to the documentation of hi_sync 0.2.0 Download hi_sync 0.2.0 archive
0.1.2 Apr 12, 2014 Go to the documentation of hi_sync 0.1.2 Download hi_sync 0.1.2 archive
0.1.1 Apr 12, 2014 Go to the documentation of hi_sync 0.1.1 Download hi_sync 0.1.1 archive
0.1.0 Apr 9, 2014 Go to the documentation of hi_sync 0.1.0 Download hi_sync 0.1.0 archive
0.0.1 Apr 3, 2014 Go to the documentation of hi_sync 0.0.1 Download hi_sync 0.0.1 archive
0.0.0 Mar 30, 2014 Go to the documentation of hi_sync 0.0.0 Download hi_sync 0.0.0 archive

Analysis

We analyzed this package on Jul 17, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
6 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
2
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Error(s) in lib/hi_sync.dart: Target of URI doesn't exist: '../../hi_files/lib/hi_files.dart'.

Suggestions

  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Error(s) in lib/hi_sync.dart: Target of URI doesn't exist: '../../hi_files/lib/hi_files.dart'.

  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Package is too old.

    The package was released more than two years ago.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 120 errors 8 hints.

    Make sure that the imported libraries are not in conflict. Error(s) in lib/hi_sync.dart: Target of URI doesn't exist: '../../hi_files/lib/hi_files.dart'.

    Strong-mode analysis of lib/log.dart failed with the following error:

    line: 0 col: 0
    is a part and cannot be analyzed.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.4.0-dev.2.2
hi_files >=0.2.0 <0.3.0 0.2.0