highcharts 0.5.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 22

Highcharts for Dart

Highcharts API wrapped via JS interop (js package).

How does it work?

First of all, add the dependency to your pubspec.yaml:

dependencies: 
  highcharts: any

Create the chart options object to be used by the polymer or the angular component:

ChartOptions chartOptions = new ChartOptions ()
    ..chart = (
        new Chart()
          ..renderTo = "output"
    )
    ..title = (new Title()..text = 'Monthly Average Temperature')
    ..subtitle = (
        new Subtitle()
          ..text = 'Source: WorldClimate.com'
          ..x = -20
    )
    ..xAxis = (
        new XAxis()
          ..categories = ['Jan', 'Feb', 'Mar', 'Apr', 'May', 'Jun',
          'Jul', 'Aug', 'Sep', 'Oct', 'Nov', 'Dec']
    )
    ..yAxis = (
        new YAxis()
          ..title = (
              new YAxisTitle()
                ..text = 'Temperature (ºC)'
          )
          ..plotLines = [
            new JsObject.jsify ({
              'value': 0,
              'width': 1,
              'color': '#808080'
            })
          ]
    )
    ..tooltip = (
        new Tooltip()..valueSuffix = 'ºC'
    )
    ..legend = (
        new Legend()
          ..layout = 'vertical'
          ..align = 'right'
          ..verticalAlign = 'middle'
          ..borderWidth = 0
    )
    ..series = [
      new Series()
        ..name = 'Tokyo'
        ..data = [7.0, 6.9, 9.5, 14.5, 18.2, 21.5, 25.2, 26.5, 23.3, 18.3, 13.9, 9.6],
      new Series()
        ..name = 'New York'
        ..data = [-0.2, 0.8, 5.7, 11.3, 17.0, 22.0, 24.8, 24.1, 20.1, 14.1, 8.6, 2.5],
      new Series()
        ..name = 'Berlin'
        ..data = [-0.9, 0.6, 3.5, 8.4, 13.5, 17.0, 18.6, 17.9, 14.3, 9.0, 3.9, 1.0],
      new Series()
        ..name = 'London'
        ..data = [3.9, 4.2, 5.7, 8.5, 11.9, 15.2, 17.0, 16.6, 14.2, 10.3, 6.6, 4.8],
    ];
  HighchartsChart chart = new HighchartsChart(chartOptions);

Disclaimer

*This is just a work in progress. This is just a piece of software to help people use Highcharts in their Dart projects, but the author is not part of the Highcharts team. * Keep in mind that if you want to use Highcharts in commercial applications, you will have to acquire a developer licence

Changelog

0.5.2

  • All the classes are generated parsing the official Highcharts API
  • @JS() directive added on top of libraries to make it work with sdk 1.17

0.0.1

  • Initial version, created by Stagehand.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  highcharts: ^0.5.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:highcharts/highcharts.dart';
  
Version Uploaded Documentation Archive
0.5.2 Jul 24, 2016 Go to the documentation of highcharts 0.5.2 Download highcharts 0.5.2 archive
0.5.1 Jul 24, 2016 Go to the documentation of highcharts 0.5.1 Download highcharts 0.5.1 archive
0.5.0+5 Apr 29, 2016 Go to the documentation of highcharts 0.5.0+5 Download highcharts 0.5.0+5 archive
0.5.0+3 Apr 28, 2016 Go to the documentation of highcharts 0.5.0+3 Download highcharts 0.5.0+3 archive
0.5.0+2 Apr 28, 2016 Go to the documentation of highcharts 0.5.0+2 Download highcharts 0.5.0+2 archive
0.5.0+1 Mar 29, 2016 Go to the documentation of highcharts 0.5.0+1 Download highcharts 0.5.0+1 archive
0.5.0 Mar 9, 2016 Go to the documentation of highcharts 0.5.0 Download highcharts 0.5.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
44
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
22
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0