highstock 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 23

highstock

A library for Dart developers. It is awesome.

Usage

A simple usage example:

import 'package:highstock/highstock.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  highstock: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:highstock/highstock.dart';
  
Version Uploaded Documentation Archive
0.0.1 Apr 3, 2016 Go to the documentation of highstock 0.0.1 Download highstock 0.0.1 archive

Analysis

We analyzed this package on May 22, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.54.0
  • pana: 0.11.1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
78 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
23
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:highstock/highstock.dart with components: html, js.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 errors 457 hints.

    Strong-mode analysis of lib/highstock.dart failed with the following error:

    line: 22476 col: 3
    Invalid override. The type of 'FlagsSeries.data=' ('(List<JsObject>) → void') isn't a subtype of 'Series.data=' ('(dynamic) → void').

    Strong-mode analysis of lib/util/js_map.dart failed with the following error:

    line: 0 col: 0
    is a part and cannot be analyzed.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use highstock.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
js ^0.6.0 0.6.1
uuid >=0.5.0 <0.6.0 0.5.3 1.0.0
Transitive dependencies
charcode 1.1.1
collection 1.14.9
convert 2.0.1
crypto 2.0.3
typed_data 1.1.5