highstock_wrapper 0.1.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 59

Highstock Dart wrapper library

GitHub release

Library that allows to use Highstock chart library in Dart applications.

Installation

Include highstock.js in your project from package asset, CDN or as bower dependency.

<script src="http://code.highcharts.com/stock/4.2.4/highstock.js"></script>

Usage

Instantiate Highstock chart library with container to render chart into:

var chart = new HighstockChart(new StockChartOptions()
  ..chart = (new Chart()
    ..renderTo = querySelector('#payments_chart')));

You can add some data to chart before rendering:

var chart = new HighstockChart(new StockChartOptions()
  ..chart = (new Chart()
    ..renderTo = querySelector('#payments_chart'))
  ..series = [new LineSeries()
    ..name = 'Demo'
    ..type = 'line'
    ..data = [0, 2, 1]]);

... or after rendering:

var chart = new HighstockChart(new StockChartOptions()
  ..chart = (new Chart()
    ..renderTo = querySelector('#payments_chart'))
  ..series = [new LineSeries()
    ..name = 'Demo'
    ..type = 'line']);
chart.series[0].setData([0, 2, 1], true, false, false);

Structure

Class hierarchy is the same as in highstock library.
Each option is mapped to the related class, so if you want to tune chart title, you should use Title class, for legend - Legend class etc.

Changelog

0.1.5

  • Changed package name.

0.1.4

  • Synced dart and github release versions.

0.1.3

  • Changed library name.

0.1.2

  • Changed package name.

0.1.1

  • Improved README.
  • Added LICENSE.
  • Removed unused files.
  • Updated Highstock library files.

0.1.0

  • Added new dart version support.
  • Added additional methods and fields.

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  highstock_wrapper: "^0.1.5"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:highstock_wrapper/highstock_wrapper.dart';
  
Version Uploaded Documentation Archive
0.1.5 Aug 12, 2016 Go to the documentation of highstock_wrapper 0.1.5 Download highstock_wrapper 0.1.5 archive

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
62 / 100
Health:
Code health derived from static analysis. [more]
80 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
16 / 100
Overall score:
Weighted score of the above. [more]
59
Learn more about scoring.

Platforms

Detected platforms: web

Primary library: package:highstock_wrapper/highstock_wrapper.dart with components: html, js.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 2 hints.

    Strong-mode analysis of lib/highstock_wrapper.dart failed with the following error:

    line: 22496 col: 3
    Invalid override. The type of 'FlagsSeries.data=' ('(List<JsObject>) → void') isn't a subtype of 'Series.data=' ('(dynamic) → void').

  • Package is getting outdated.

    The package was released 95 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use highstock_wrapper.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
js ^0.6.0 0.6.1
uuid >=0.5.0 <0.6.0 0.5.3 1.0.0
Transitive dependencies
charcode 1.1.1
collection 1.14.10
convert 2.0.1
crypto 2.0.3
typed_data 1.1.5