highstock_wrapper 0.1.5

  • README.md
  • Installing
  • Versions
  • 0

Highstock Dart wrapper library #

GitHub release

Library that allows to use Highstock chart library in Dart applications.

Installation #

Include highstock.js in your project from package asset, CDN or as bower dependency.

<script src="http://code.highcharts.com/stock/4.2.4/highstock.js"></script>

Usage #

Instantiate Highstock chart library with container to render chart into:

var chart = new HighstockChart(new StockChartOptions()
  ..chart = (new Chart()
    ..renderTo = querySelector('#payments_chart')));

You can add some data to chart before rendering:

var chart = new HighstockChart(new StockChartOptions()
  ..chart = (new Chart()
    ..renderTo = querySelector('#payments_chart'))
  ..series = [new LineSeries()
    ..name = 'Demo'
    ..type = 'line'
    ..data = [0, 2, 1]]);

... or after rendering:

var chart = new HighstockChart(new StockChartOptions()
  ..chart = (new Chart()
    ..renderTo = querySelector('#payments_chart'))
  ..series = [new LineSeries()
    ..name = 'Demo'
    ..type = 'line']);
chart.series[0].setData([0, 2, 1], true, false, false);

Structure #

Class hierarchy is the same as in highstock library.
Each option is mapped to the related class, so if you want to tune chart title, you should use Title class, for legend - Legend class etc.

Changelog #

0.1.5 #

  • Changed package name.

0.1.4 #

  • Synced dart and github release versions.

0.1.3 #

  • Changed library name.

0.1.2 #

  • Changed package name.

0.1.1 #

  • Improved README.
  • Added LICENSE.
  • Removed unused files.
  • Updated Highstock library files.

0.1.0 #

  • Added new dart version support.
  • Added additional methods and fields.

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  highstock_wrapper: ^0.1.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:highstock_wrapper/highstock_wrapper.dart';
Version Uploaded Documentation Archive
0.1.5 Aug 12, 2016 Go to the documentation of highstock_wrapper 0.1.5 Download highstock_wrapper 0.1.5 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0