html 0.13.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 98

html5 parser in dart

This is a pure Dart html5 parser. It's a port of html5lib from Python. Since it's 100% Dart you can use it safely from a script or server side app.

Eventually the parse tree API will be compatible with dart:html, so the same code will work on the client and the server.

(Formerly known as html5lib.)

Installation

Add this to your pubspec.yaml (or create it):

dependencies:
  html: any

Then run the Pub Package Manager (comes with the Dart SDK):

pub install

Usage

Parsing HTML is easy!

import 'package:html/parser.dart' show parse;
import 'package:html/dom.dart';

main() {
  var document = parse(
      '<body>Hello world! <a href="www.html5rocks.com">HTML5 rocks!');
  print(document.outerHtml);
}

You can pass a String or list of bytes to parse. There's also parseFragment for parsing a document fragment, and HtmlParser if you want more low level control.

Running Tests

./test/run.sh

0.13.2

  • Support the latest release of pkg/csslib.

0.13.1

  • Update Set.difference to take a Set<Object>.

0.13.0

  • BREAKING Fix all strong mode errors and warnings. This involved adding more precise types on some public APIs, which is why it may break users.

Pub version 0.12.2+2

  • Support csslib versions 0.13.x.

Pub version 0.12.2+1

  • Exclude .packages file from the published package.

Pub version 0.12.2

  • Added Element.endSourceSpan, containing the span of a closing tag.

Pub version 0.12.0+1

  • Support csslib version 0.12.0.

Rename to package:html 0.12.0

  • package has been renamed to html

Pub version 0.12.0

  • switch from source_maps' Span class to source_span's SourceSpan class.

Pub version 0.11.0+2

  • expand the version constraint for csslib.

Pub version 0.10.0+1

  • use a more recent source_maps version.

Pub version 0.10.0

  • fix how document fragments are added in NodeList.add/addAll/insertAll.

Pub version 0.9.2-dev

  • add Node.text, Node.append, Document.documentElement
  • add Text.data, deprecate Node.value and Text.value.
  • deprecate Node.$dom_nodeType
  • added querySelector/querySelectorAll, deprecated query/queryAll. This matches the current APIs in dart:html.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  html: "^0.13.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:html/dom.dart';

import 'package:html/dom_parsing.dart';

import 'package:html/parser.dart';

import 'package:html/parser_console.dart';
        
Version Uploaded Documentation Archive
0.13.2 May 31, 2017 Go to the documentation of html 0.13.2 Download html 0.13.2 archive
0.13.1 Oct 24, 2016 Go to the documentation of html 0.13.1 Download html 0.13.1 archive
0.13.0 May 11, 2016 Go to the documentation of html 0.13.0 Download html 0.13.0 archive
0.12.2+2 Apr 21, 2016 Go to the documentation of html 0.12.2+2 Download html 0.12.2+2 archive
0.12.2+1 Dec 17, 2015 Go to the documentation of html 0.12.2+1 Download html 0.12.2+1 archive
0.12.2 Aug 28, 2015 Go to the documentation of html 0.12.2 Download html 0.12.2 archive
0.12.1+2 Jul 6, 2015 Go to the documentation of html 0.12.1+2 Download html 0.12.1+2 archive
0.12.1+1 Apr 3, 2015 Go to the documentation of html 0.12.1+1 Download html 0.12.1+1 archive
0.12.1 Mar 5, 2015 Go to the documentation of html 0.12.1 Download html 0.12.1 archive

Analysis

This feature is new.
We welcome feedback.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Dec 6, 2017
  • Dart: 2.0.0-dev.8.0
  • pana: 0.7.3+1

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
97
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
99
Overall score:
Weighted score of the above. [more]
98

Platforms

Detected platforms: Flutter, server

all of the above

Suggestions

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
csslib >=0.13.2 <0.15.0 0.14.1
source_span >=1.0.0 <2.0.0 1.4.0
utf >=0.9.0 <0.10.0 0.9.0+3
Transitive dependencies
args 1.2.0
charcode 1.1.1
logging 0.11.3+1
Dev dependencies
path >=0.9.0 <2.0.0 1.5.1
unittest >=0.10.0 <0.12.0