This library is an HTML library generated by html_wrapper_generator
starting from webidl files (stolen from the
firefox project and then adapted).
It leverages the
@JS interop Dart layer and aims to completely replace the (at the moment) out dated
As a separate package from the
SDK this library has the main advantage to be updated more frequently.
Notably this library adds support to latest standards:
See here for a demo project using
polymerize and this library.
httpin a different package
DocumentOrShadowRootis not implemented in
ShadyDOM(=> Firefox, etc.) see here
Add this to your package's pubspec.yaml file:
dependencies: html5: ^0.1.8
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
import 'package:html5/html.dart'; import 'package:html5/html.polymerize.dart'; import 'package:html5/html5_support.dart'; import 'package:html5/html5_support.polymerize.dart'; import 'package:html5/html_addendum.dart'; import 'package:html5/html_gen.dart';
|0.1.8||Oct 31, 2017|
|0.1.7||Jul 15, 2017|
|0.1.6||Jul 4, 2017|
|0.1.5||Jun 30, 2017|
|0.1.4||Jun 18, 2017|
|0.1.3||Jun 14, 2017|
|0.1.2+2||Jun 14, 2017|
|0.1.2+1||Jun 14, 2017|
|0.1.2||Jun 14, 2017|
|0.1.1||Jun 14, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.8.0 <2.0.0|