http2 0.1.8+2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 86

HTTP/2 for Dart

Note: This is a work in progress and experimental.

See the API docs for more details and sample code.

Features and bugs

Please file feature requests and bugs at the issue tracker.

0.1.8+2

  • On connection termination, try to dispatch existing messages, thereby avoiding terminating existing streams.

  • Fix ClientTransportConnection.isOpen to return false if we have exhausted the number of max-concurrent-streams.

0.1.8+1

  • Switch all uppercase constants from dart:convert to lowercase.

0.1.8

  • More changes required for making tests pass under Dart 2.0 runtime.
  • Modify sdk constraint to require '>=2.0.0-dev.40.0'.

0.1.7

  • Fixes for Dart 2.0.

0.1.6

  • Strong mode fixes and other cleanup.

0.1.5

  • Removed use of new Function syntax, since it isn't fully supported in Dart 1.24.

0.1.4

  • Added an onActiveStateChanged callback to Connection, which is invoked when the connection changes state from idle to active or from active to idle. This can be used to implement an idle connection timeout.

0.1.3

  • Fixed a bug where a closed window would not open correctly due to an increase in initial window size.

0.1.2

  • The endStream bit is now set on the requested frame, instead of on an empty data frame following it.
  • Added an onTerminated hook that is called when a TransportStream receives a RST_STREAM frame.

0.1.1+2

  • Add errorCode to exception toString message.

0.1.1+1

  • Fixing a performance issue in case the underlying socket is not writeable
  • Allow clients of MultiProtocolHttpServer to supply [http.ServerSettings]
  • Allow the draft version 'h2-14' in the ALPN protocol negogiation.

0.1.1

  • Adding support for MultiProtocolHttpServer in the package:http2/multiprotocol_server.dart library

0.1.0

  • First version of a HTTP/2 transport implementation in the package:http2/transport.dart library

0.0.1

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http2: ^0.1.8+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http2/multiprotocol_server.dart';
import 'package:http2/transport.dart';
  
Version Uploaded Documentation Archive
0.1.8+2 Jul 16, 2018 Go to the documentation of http2 0.1.8+2 Download http2 0.1.8+2 archive
0.1.8+1 Jul 12, 2018 Go to the documentation of http2 0.1.8+1 Download http2 0.1.8+1 archive
0.1.8 Mar 21, 2018 Go to the documentation of http2 0.1.8 Download http2 0.1.8 archive
0.1.7 Jan 11, 2018 Go to the documentation of http2 0.1.7 Download http2 0.1.7 archive
0.1.6 Nov 3, 2017 Go to the documentation of http2 0.1.6 Download http2 0.1.6 archive
0.1.5 Oct 5, 2017 Go to the documentation of http2 0.1.5 Download http2 0.1.5 archive
0.1.4 Oct 2, 2017 Go to the documentation of http2 0.1.4 Download http2 0.1.4 archive
0.1.3 Jul 18, 2017 Go to the documentation of http2 0.1.3 Download http2 0.1.3 archive
0.1.2 Jul 5, 2017 Go to the documentation of http2 0.1.2 Download http2 0.1.2 archive
0.1.1+2 Mar 17, 2017 Go to the documentation of http2 0.1.1+2 Download http2 0.1.1+2 archive

All 13 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
71
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
86
Learn more about scoring.

We analyzed this package on Aug 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8

Platforms

Detected platforms: Flutter, other

Platform components identified in package: io.

Suggestions

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use http2.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.56.0 <3.0.0
Dev dependencies
mockito ^3.0.0-beta+2
test ^1.2.0