http2_bridge 1.0.0-alpha

  • Installing
  • Versions
  • 0

http2_bridge #


Handle HTTP/2 requests as if they were dart:io HttpRequests.

This package is currently in alpha, mainly because I have no practical idea of how to test it. Stay tuned.

Usage #

Use the adaptHttp2Stream function to bridge HTTP/2 requests to an existing HTTP/1.1 handler.

import 'dart:io';
import 'package:http2/multiprotocol_server.dart';
import 'package:http2_bridge/http2_bridge.dart';

main() async {
  var ctx = new SecurityContext();
  var server = await MultiProtocolServer.bind('', 443, ctx);
    // Serve HTTP/1.1 as normal
    // Handle HTTP/2 streams as though they were HTTP/1.1 requests...

handleRequest(HttpRequest request) async {
  // Do something...

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  http2_bridge: ^1.0.0-alpha

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:http2_bridge/http2_bridge.dart';
Version Uploaded Documentation Archive
1.0.0-alpha Jul 3, 2017 Go to the documentation of http2_bridge 1.0.0-alpha Download http2_bridge 1.0.0-alpha archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0