http_exception 0.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 21

HTTP Exceptions

A set of predefined exception classes for HTTP errors extracted from shelf_exception_response.

License

Apache 2.0

0.1.0

  • created this package consisting only of the exception classes from the shelf_exception_response package.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_exception: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_exception/http_exception.dart';
  
Version Uploaded Documentation Archive
0.1.0 Apr 1, 2015 Go to the documentation of http_exception 0.1.0 Download http_exception 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
21
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0