http_logger 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new28

http_logger

A logging middleware for Dart's http module.

Usage

http_logger uses the http_middleware package to implement logging.

Add the http_middleware and http_logger in your project.

http_middleware: any
http_logger: any

The setup is simple. You need to create an object of HttpWithMiddleware or HttpClientWithMiddleware and add the HttpLogger middleware in it.

HttpWithMiddleware httpClient = HttpWithMiddleware.build(middlewares: [
  HttpLogger(logLevel: LogLevel.BODY),
]);

var response = await httpClient.post(
  'https://jsonplaceholder.typicode.com/posts/',
  body: jsonEncode({"test1": "THis is a test"}),
  headers: {"Content-Type": "application/json"});

There are different log levels that you can use.

LogLevel.BODY
LogLevel.HEADER
LogLevel.BASIC
LogLevel.NONE

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_logger: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_logger/http_logger.dart';
  
Version Uploaded Documentation Archive
0.0.3 Jul 23, 2018 Go to the documentation of http_logger 0.0.3 Download http_logger 0.0.3 archive
0.0.2 Jul 23, 2018 Go to the documentation of http_logger 0.0.2 Download http_logger 0.0.2 archive
0.0.1 Jul 19, 2018 Go to the documentation of http_logger 0.0.1 Download http_logger 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
56
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0