http_parser is a platform-independent package for parsing and serializing
various HTTP-related formats. It's designed to be usable on both the browser and
the server, and thus avoids referencing any types from
Support for parsing and formatting dates according to HTTP/1.1, the HTTP/1.1 standard.
MediaType class that represents an HTTP media type, as used in
Content-Type headers. This class supports both parsing and formatting
media types according to HTTP/1.1.
WebSocketChannel class that provides a
StreamChannel interface for both
the client and server sides of the WebSocket protocol independently of
any specific server implementation.
<3.0.0, and adjust other dependencies.
Require Dart SDK 2.0.0-dev.17.0 or greater.
A number of strong-mode fixes.
chunkedCodingcodec. It had been producing invalid output and rejecting valid input.
Codecthat supports encoding and decoding the chunked transfer coding.
All deprecated APIs have been removed. No new APIs have been added. Packages
that would use 3.0.0 as a lower bound should use 2.2.0 instead—for example,
http_parser: ">=2.2.0 <4.0.0".
Fix all strong-mode warnings.
WebSocketChannelhas been moved to the
web_socket_channelpackage. The implementation here is now deprecated.
WebSocketChannel, an implementation of
StreamChannel that's backed
CompatibleWebSocket in favor of
DataUriclass. It's redundant with the
Uri.datagetter that's coming in Dart 1.14, and the
DataUri.datafield in particular was an invalid override of that field.
MediaTypenow uses a case-insensitive map for its parameters and its
subtypefields are now always lowercase.
This is 1.0.0 because the API is stable—there are no breaking changes.
AuthenticationChallenge class for parsing and representing the
WWW-Authenticate and related headers.
CaseInsensitiveMap class for representing case-insensitive HTTP
CompatibleWebSocket, for platform- and API-independent support for the WebSocket API.
Add this to your package's pubspec.yaml file:
dependencies: http_parser: ^3.1.3
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|3.1.3||Jul 19, 2018|
|3.1.2||May 2, 2018|
|3.1.1||Dec 15, 2016|
|3.1.0||Dec 6, 2016|
|3.0.3||Oct 12, 2016|
|3.0.2||Jun 20, 2016|
|3.0.1||May 19, 2016|
|3.0.0||May 5, 2016|
|2.2.1||Mar 23, 2016|
|2.2.0||Mar 3, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, web, other
No platform restriction found in primary library
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
|Dart SDK||>=2.0.0-dev.17.0 <3.0.0|