http_parser 2.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • --

http_parser is a platform-independent package for parsing and serializing various HTTP-related formats. It's designed to be usable on both the browser and the server, and thus avoids referencing any types from dart:io or dart:html. It includes:

  • Support for parsing and formatting dates according to HTTP/1.1, the HTTP/1.1 standard.

  • A MediaType class that represents an HTTP media type, as used in Accept and Content-Type headers. This class supports both parsing and formatting media types according to HTTP/1.1.

  • A CompatibleWebSocket class that supports both the client and server sides of the WebSocket protocol independently of any specific server implementation.

2.0.0

  • Removed the DataUri class. It's redundant with the Uri.data getter that's coming in Dart 1.14, and the DataUri.data field in particular was an invalid override of that field.

1.1.0

  • The MIME spec says that media types and their parameter names are case-insensitive. Accordingly, MediaType now uses a case-insensitive map for its parameters and its type and subtype fields are now always lowercase.

1.0.0

This is 1.0.0 because the API is stable—there are no breaking changes.

  • Added an AuthenticationChallenge class for parsing and representing the value of WWW-Authenticate and related headers.

  • Added a CaseInsensitiveMap class for representing case-insensitive HTTP values.

0.0.2+8

  • Bring in the latest dart:io WebSocket code.

0.0.2+7

  • Add more detail to the readme.

0.0.2+6

  • Updated homepage URL.

0.0.2+5

  • Widen the version constraint on the collection package.

0.0.2+4

  • Widen the string_scanner version constraint.

0.0.2+3

  • Fix a library name conflict.

0.0.2+2

  • Fixes for HTTP date formatting.

0.0.2+1

  • Minor code refactoring.

0.0.2

  • Added CompatibleWebSocket, for platform- and API-independent support for the WebSocket API.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  http_parser: "^2.0.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:http_parser/http_parser.dart';
        
Version Uploaded Documentation Archive
3.1.1 Dec 15, 2016 Go to the documentation of http_parser 3.1.1 Download http_parser 3.1.1 archive
3.1.0 Dec 6, 2016 Go to the documentation of http_parser 3.1.0 Download http_parser 3.1.0 archive
3.0.3 Oct 12, 2016 Go to the documentation of http_parser 3.0.3 Download http_parser 3.0.3 archive
3.0.2 Jun 20, 2016 Go to the documentation of http_parser 3.0.2 Download http_parser 3.0.2 archive
3.0.1 May 19, 2016 Go to the documentation of http_parser 3.0.1 Download http_parser 3.0.1 archive
3.0.0 May 5, 2016 Go to the documentation of http_parser 3.0.0 Download http_parser 3.0.0 archive
2.2.1 Mar 23, 2016 Go to the documentation of http_parser 2.2.1 Download http_parser 2.2.1 archive
2.2.0 Mar 3, 2016 Go to the documentation of http_parser 2.2.0 Download http_parser 2.2.0 archive
2.1.0 Jan 28, 2016 Go to the documentation of http_parser 2.1.0 Download http_parser 2.1.0 archive
2.0.0 Dec 14, 2015 Go to the documentation of http_parser 2.0.0 Download http_parser 2.0.0 archive

All 22 versions...

Analysis

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.